From: Todd M. Sahba (sahba@xxxxxxxxxx)
Date: Wed Sep 29 1999 - 10:50:38 GMT-3
Ive run into problems getting NLSP neighbors to see each other. Im hoping
someone can give me some insight into this problem.
Heres the setup:
[r1] serial0/0 ----------- HDLC --------serial0/0 [r3]
Ive enabled nlsp, set the area-address to 0 0, enabled nlsp on the
interfaces and disabled rip and sap. (configs are below).
No adjacency is being formed, and when I debug ipx nlsp adj on r1 I dont
see any receives:
21:45:07: NLSP-Adj: Sending serial IIH on Serial0/0
21:45:15: NLSP-Adj: Sending serial IIH on Serial0/0
21:45:24: NLSP-Adj: Sending serial IIH on Serial0/0
21:45:34: NLSP-Adj: Sending serial IIH on Serial0/0
On r3 I see both sends and receives:
21:46:39: NLSP-Adj: Sending serial IIH on Serial0/0
21:46:41: NLSP-Adj: Rec serial IIH from *HDLC* (Serial0/0), cir type L1, cir
id
04
21:46:41: NLSP-Adj: old state INIT, new state INIT
21:46:49: NLSP-Adj: Sending serial IIH on Serial0/0
21:46:51: NLSP-Adj: Rec serial IIH from *HDLC* (Serial0/0), cir type L1, cir
id
04
21:46:51: NLSP-Adj: old state INIT, new state INIT
On r1, when I debug ipx packet I see a bad packet coming from r3:
21:54:19: IPX: Se0/0:3000.0000.0000.0001->0.ffff.ffff.ffff ln= 66 tc=00
pt=00 ds
=9001 ss=9001, rcvd
21:54:19: IPX: Se0/0:3000.0000.0000.0001->0.ffff.ffff.ffff ln= 66 tc=00
pt=00 ds
=9001 ss=9001, bad pkt
Here are my configurations:
r1#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
no ip subnet-zero
no ip domain-lookup
ipx routing 0000.0000.0001
ipx internal-network 1000
!
!
!
interface Loopback0
ip address 140.10.11.1 255.255.255.0
no ip directed-broadcast
ipx network 11
!
interface Ethernet0/0
mac-address 0000.0000.0001
ip address 140.10.10.1 255.255.255.0
no ip directed-broadcast
ipx network 10
!
interface Serial0/0
ip address 140.100.13.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
ipx network 13
ipx nlsp enable
ipx nlsp rip off
ipx nlsp sap off
clockrate 64000
!
interface Serial0/1
no ip address
no ip directed-broadcast
!
router igrp 15
network 140.100.0.0
!
ip classless
!
!
!
ipx router nlsp
area-address 0 0
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
r1#
r3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0000.0000.0003
ipx internal-network 3000
!
!
!
!
interface FastEthernet0/0
ip address 140.100.235.3 255.255.255.192
no ip directed-broadcast
ip ospf priority 0
ipx network 235
!
interface Serial0/0
ip address 140.100.13.3 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
ipx network 13
ipx nlsp enable
ipx nlsp rip off
ipx nlsp sap off
!
interface Serial0/1
ip address 140.100.35.3 255.255.255.0
no ip directed-broadcast
ipx network 35
clockrate 128000
!
!
router ospf 1
redistribute igrp 15 metric 10 subnets
network 140.100.35.3 0.0.0.0 area 0
network 140.100.235.3 0.0.0.0 area 0
!
router igrp 15
redistribute ospf 1 metric 10 100 255 10 100
passive-interface FastEthernet0/0
passive-interface Serial0/1
network 140.100.0.0
!
ip classless
ip default-network 150.100.0.0
no ip http server
!
!
!
!
ipx router nlsp
area-address 0 0
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
r3#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:51 GMT-3