mpls vpn can not work?

From: ciscoguy (ciscoguy@xxxxxxxx)
Date: Sat Jan 01 2000 - 01:01:01 GMT-3


   
hi all :
    When I do the vpn test,I meet the question,CE_2 can not ping CE_1.
CE_2--S0 12.1.1.1-----S0/0 12.1.1.2-------------------PE_2-E0/0 23.1.1.2

                                     34.1.1.3 S0/0--r3 -----f0/0 23.1.1.3
                                                |
CE_1--E0 45.1.1.5-------------E0/0 45.1.1.4---PE_1----S0/0 34.1.1.4
THE CONFIG:
CE_1:
interface Loopback0
 ip address 50.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 45.1.1.5 255.255.255.0
!
router rip
 version 2
 network 45.0.0.0
 network 50.0.0.0
 no auto-summary
!
PE_1: ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
ip cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 45.1.1.4 255.255.255.0
!
interface Serial0/0
 ip address 34.1.1.4 255.255.255.0
 tag-switching ip
!
router ospf 1
 network 3.3.3.3 0.0.0.0 area 0
 network 34.1.1.4 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vpn1
 version 2
 redistribute bgp 888 metric 2
 network 45.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 888
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 888
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vpn1
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 2.2.2.2 activate
 neighbor 2.2.2.2 next-hop-self
 neighbor 2.2.2.2 send-community extended
 no auto-summary
 exit-address-family
! r3:
!
!
ip cef
!
interface FastEthernet0/0
 ip address 23.1.1.3 255.255.255.0
 tag-switching ip
!
interface Serial0/0
 ip address 34.1.1.3 255.255.255.0
 tag-switching ip
!
router ospf 1
 network 23.1.1.3 0.0.0.0 area 0
 network 34.1.1.3 0.0.0.0 area 0
!
PE_2
!
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 23.1.1.2 255.255.255.0
 tag-switching ip
!
interface Serial0/0
 ip vrf forwarding vpn1
 ip address 12.1.1.2 255.255.255.0
!
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 23.1.1.2 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vpn1
 version 2
 redistribute bgp 888 metric 2
 network 12.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 888
 no synchronization
 no bgp default ipv4-unicast
 no bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 888
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 3.3.3.3 activate
 neighbor 3.3.3.3 next-hop-self
 neighbor 3.3.3.3 send-community extended
 exit-address-family
!
CE_2
!
interface Loopback100
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.217.100 255.255.0.0
!
interface Serial0
 ip address 12.1.1.1 255.255.255.0
!
!
router rip
 version 2
 network 10.0.0.0
 network 12.0.0.0
 no auto-summary
!



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:32 GMT-3