Re: Frame Relay Switch with 2 Routers

From: Rob Hopkins (rshopkins@xxxxxxxxxxxxx)
Date: Fri Apr 20 2001 - 14:04:17 GMT-3


   
below are the two configs for the frame switches (2501 equiv.) connected in
tandem via the aux port,
pvcs are setup as follows:

full mesh with 3 pvcs

R3-S0 (30)
R3-S1 (31)
R4-S0 (40)

I used loopbacks so I could create more than 1 tunnel between the two
routers, you could add
to this config to create 4 pvcs fully meshed (use r4 s1), you would need to
add two more loopbacks and two
more tunnels, but you should get the idea. I also used a static route on
both routers, the idea being that is a
subnet not used in other labs, so you could essentially bind any ip to the
ethernet ports and any protocol,
as long as you dont trip over the 1.0.0.0 network..... hope this helps..

Thanks,

Rob Hopkins

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

hostname r3
!
enable password cisco
!
no ip domain-lookup
frame-relay switching
!
interface Loopback3040
 ip address 1.30.40.3 255.255.255.255
!
interface Loopback3140
 ip address 1.31.40.3 255.255.255.255
!
interface Tunnel3040
 no ip address
 tunnel source Loopback3040
 tunnel destination 1.30.40.4
!
interface Tunnel3140
 no ip address
 tunnel source Loopback3140
 tunnel destination 1.31.40.4
!
interface Ethernet0
 ip address 10.254.172.203 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 clockrate 1000000
 frame-relay intf-type dce
 frame-relay route 31 interface Serial1 30
 frame-relay route 40 interface Tunnel3040 400
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 1000000
 frame-relay intf-type dce
 frame-relay route 30 interface Serial0 31
 frame-relay route 40 interface Tunnel3140 401
!
interface Async1
 ip address 1.1.1.3 255.255.255.0
 encapsulation ppp
 async default routing
 async dynamic routing
 async mode dedicated
 no cdp enable
!
ip host r1 10.254.172.201
ip host r2 10.254.172.202
ip host r3 10.254.172.203
ip host r4 10.254.172.204
ip host r5 10.254.172.205
ip host tftp 10.254.172.102
ip route 1.0.0.0 255.0.0.0 1.1.1.4
!
line con 0
line aux 0
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 password cisco
 login
!
end
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
hostname r4
!
enable password cisco
!
ip subnet-zero
frame-relay switching
!
interface Loopback3040
 ip address 1.30.40.4 255.255.255.255
!
interface Loopback3140
 ip address 1.31.40.4 255.255.255.255
!
interface Tunnel3040
 no ip address
 tunnel source Loopback3040
 tunnel destination 1.30.40.3
!
interface Tunnel3140
 no ip address
 tunnel source Loopback3140
 tunnel destination 1.31.40.3
!
interface Ethernet0
 ip address 10.254.172.204 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 clockrate 1000000
 frame-relay intf-type dce
 frame-relay route 30 interface Tunnel3040 400
 frame-relay route 31 interface Tunnel3140 401
!
interface Serial1
 no ip address
 encapsulation frame-relay
 shutdown
 clockrate 1000000
 frame-relay intf-type dce
!
interface TokenRing0
 no ip address
 shutdown
!
interface Async1
 ip address 1.1.1.4 255.255.255.0
 encapsulation ppp
 async default routing
 async dynamic routing
 async mode dedicated
 no cdp enable
!
ip host r1 10.254.172.201
ip host r2 10.254.172.202
ip host r3 10.254.172.203
ip host r4 10.254.172.204
ip host r5 10.254.172.205
ip route 1.0.0.0 255.0.0.0 1.1.1.3
!
line con 0
line aux 0
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 300 0
 password cisco
 login
!
end

----- Original Message -----
From: "rsevier" <rsevier@zealousolutions.com>
To: "Rob Hopkins" <rshopkins@earthlink.net>; <ccielab@groupstudy.com>
Sent: Friday, April 20, 2001 9:35 AM
Subject: RE: Frame Relay Switch with 2 Routers

> Rob- I have been trying to do your poor man's frame switch through the
aux
> port and have been unsuccessful. Is there a version of code that this
> relates to?
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> Rob Hopkins
> Sent: Thursday, April 19, 2001 6:25 PM
> To: ccielab@groupstudy.com
> Subject: Fw: Frame Relay Switch with 2 Routers
>
>
> ----- Original Message -----
> From: "Rob Hopkins" <rshopkins@earthlink.net>
> To: "Elias Aggelidis" <eaggel@algo.com.gr>
> Sent: Thursday, April 19, 2001 8:45 PM
> Subject: Re: Frame Relay Switch with 2 Routers
>
>
> > its great for us poor guys with several 2501's, you can create a 4 port
> > switch
> > with 2 2501's, setup the AUX port on both routers, use a cisco rolled
> cable
> > between the two ports to route ip, setup the tunnel to run over the aux
> > conenction,
> > which leaves you the ethernet ports for anything you want..
> >
> > i'll include the config in case anybody hasnt already seen it...
> >
> >
> > Router 1
> > -=-=-=-=-=-=-=-=
> >
> > interface Async1
> > ip address 12.1.5.1 255.255.255.0
> > encapsulation ppp
> > async default routing
> > async dynamic routing
> > async mode dedicated
> > !
> > line aux 0
> > modem InOut
> > transport input all
> > rxspeed 38400
> > txspeed 38400
> > flowcontrol hardware
> >
> >
> >
> >
> >
> >
> > Router 2
> > -=-=-=-=-=-=-=-=
> >
> > interface Async1
> > ip address 12.1.5.2 255.255.255.0
> > encapsulation ppp
> > async default routing
> > async dynamic routing
> > async mode dedicated
> > !
> > line aux 0
> > modem InOut
> > transport input all
> > rxspeed 38400
> > txspeed 38400
> > flowcontrol hardware
> >
> >
> >
> >
> >
> >
> >
> > ----- Original Message -----
> > From: "Elias Aggelidis" <eaggel@algo.com.gr>
> > To: "Padhu (LFG)" <padhu@steinroe.com>; "'Johnny Dedon'"
> > <johnny.dedon@exodus.net>; "Carl Phelan" <carlphelan@hotmail.com>;
> > <ccielab@groupstudy.com>
> > Sent: Thursday, April 19, 2001 7:35 PM
> > Subject: RE: Frame Relay Switch with 2 Routers
> >
> >
> > > I did now the existence of this command !
> > >
> > > What exactly you can achieve with this command ?
> > >
> > > Any examples ?
> > >
> > > Regards
> > >
> > > ****************************************************************
> > > Elias Aggelidis ALGOSYSTEMS SA
> > > Senior Network Engineer 4, Sardeon Str
> > > CCNA, CCNP Nea Smyrni
> > > CVOICE, Security Specialised
> > > PICA Administrator
> > > Athens 17121
> > > tel: +301-9310281 GREECE
> > > fax: +301-9352873
> > > email: eaggel@algo.com.gr
> > > ****************************************************************
> > >
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > Padhu
> > > (LFG)
> > > Sent: ?a?as?e??, 20 ?p?????? 2001 2:07 p5
> > > To: 'Johnny Dedon'; Carl Phelan; ccielab@groupstudy.com
> > > Subject: RE: Frame Relay Switch with 2 Routers
> > >
> > >
> > > Yes,
> > > You can do frame-relay switching over tunnel interfaces...The only
thing
> > to
> > > watch out is the DLCI's are mapped currently in the frame routes...For
> the
> > > sake of simplicity use the same
> > > numbers all over and it should work.
> > >
> > > Cheers,Padhu
> > >
> > > -----Original Message-----
> > > From: Johnny Dedon [mailto:johnny.dedon@exodus.net]
> > > Sent: Thursday, April 19, 2001 5:55 PM
> > > To: Carl Phelan; ccielab@groupstudy.com
> > > Subject: Re: Frame Relay Switch with 2 Routers
> > >
> > >
> > > Carl,
> > > I haven't read this document but I don't think there is a way to do
> > > frame-relay switching over anything but a serial connection.
> > > Johnny
> > > ----- Original Message -----
> > > From: "Carl Phelan" <carlphelan@hotmail.com>
> > > To: <ccielab@groupstudy.com>
> > > Sent: Thursday, April 19, 2001 5:40 PM
> > > Subject: Frame Relay Switch with 2 Routers
> > >
> > >
> > > > Hi,
> > > >
> > > > I am following the document from CCprep to create a frame relay
switch
> > > from
> > > > two 2501s. When I come to enter the following command:
> > > > 'frame-relay route 501 interface t0 105'
> > > > in interface mode on Serial 1, the router reports an error in the
> > command
> > > > syntax with 't' or even the full word 'tunnel'. When I replace 't0'
> > with
> > > a ?
> > > > the response is that it only expects the word 'serial'.
> > > > I have tried IOS ver 11.1, 11.2 and 12.0 with the same problem on
> > > different
> > > > routers - anybody have any ideas?
> > > >
> > > > Thanks.
> > > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:52 GMT-3