Re: Follow-up - ISDN PAP

From: RAMIL (ramil@xxxxxxxxxxx)
Date: Mon May 07 2001 - 01:44:59 GMT-3


   
i think this is wrong but maybe i'm confused. callin on R4 authenticates
R6(when r6 calls) thus R6 needs sent-username.

----- Original Message -----
From: "Bill Dellamar" <wdellamar@yahoo.com>
To: "Jack Reynolds" <jacreyno@cisco.com>; "Brian Hescock"
<bhescock@cisco.com>
Cc: "Ccielab" <ccielab@groupstudy.com>
Sent: Sunday, January 28, 2001 4:42 PM
Subject: RE: Follow-up - ISDN PAP

> Here it is with one-way pap authentication.
> ROUTER 4
> hostname r4
> !
> isdn switch-type basic-ni
> !
> interface Ethernet0
> ip address 1.1.1.1 255.255.255.0
> no ip directed-broadcast
> !
> interface BRI0
> no ip address
> no ip directed-broadcast
> encapsulation ppp
> dialer pool-member 1
> isdn switch-type basic-ni
> isdn spid1 0835866101
> isdn spid2 0835866301
> ppp authentication pap callin
> !
> interface Dialer0
> ip address 1.1.46.1 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> dialer remote-name remote6
> dialer string 8358662
> dialer pool 1
> dialer-group 1
> ppp authentication pap callin
> ppp pap sent-username remote4 password 7 083318
> !
> router eigrp 1
> network 1.0.0.0
> no auto-summary
> !
> dialer-list 1 protocol ip permit
>
> !
> end
>
>
> ROUTER 6
> hostname r6
> !
> username remote4 password 0 r4
> isdn switch-type basic-ni
> !
> interface TokenRing0
> ip address 1.1.6.6 255.255.255.0
> no ip directed-broadcast
> ring-speed 16
> !
> interface BRI0
> no ip address
> no ip directed-broadcast
> encapsulation ppp
> dialer pool-member 1
> isdn switch-type basic-ni
> isdn spid1 0835866201
> isdn spid2 0835866401
> ppp authentication pap
> !
> interface Dialer0
> ip address 1.1.46.2 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> dialer remote-name remote4
> dialer pool 1
> dialer-group 1
> ppp authentication pap
> !
> router eigrp 1
> network 1.0.0.0
> no auto-summary
> !
> ip classless
>
> end
>
> r6#
>
>
>
> --- Jack Reynolds <jacreyno@cisco.com> wrote:
> > Excellent. Try it with IOS other than 12.0(9) =)
> >
> >
> ------------------------------------------------------------------
> > Jack Reynolds Cisco Systems 3636 Nobel
> > Drive, Suite 150
> > Systems Engineer II || || San Diego,
> > California 92122
> > jacreyno@cisco.com :||: :||: Phone:
> > (858)658-7832
> > www.cisco.com ..:||||:...:||||:.. Pager:
> > (800)365-4578
> >
> ------------------------------------------------------------------
> >
> > -----Original Message-----
> > From: Brian Hescock [mailto:bhescock@cisco.com]
> > Sent: Sunday, January 28, 2001 12:16 PM
> > To: Jack Reynolds
> > Cc: Ccielab
> > Subject: Re: Follow-up - ISDN PAP
> >
> >
> > I believe it will work with dialer profiles as well
> > but there's a bug with
> > it, which is why you end up having to use "ppp pap
> > sent-username". But
> > "sent-username" is somewhat confusing, you have to
> > be careful which
> > hostname you specify with which password. It's on
> > my list of things to
> > review again next week, I'll let you know if I get
> > it working with dialer
> > profiles.
> >
> > B.
> >
> > On Sun, 28 Jan 2001, Jack Reynolds wrote:
> >
> > > OK, I got this working, but here is what I had to
> > do... Both R3 and R5
> > are
> > > running 12.0(9). I had to get rid of my dialer
> > profiles and go BACK to
> > > dialer maps on the physical bri's. This is the
> > only way PAP auth would
> > > work.
> > >
> > > Thanks for all the replies. Has anyone else see
> > this problem?
> > >
> > > JR
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: Jack Reynolds [mailto:jacreyno@cisco.com]
> > > Sent: Sunday, January 28, 2001 10:46 AM
> > > To: Kyle Galusha; Bernard Dunn
> > > Subject: RE: ISDN PAP
> > >
> > >
> > > Tried it, but still no worky.
> > >
> > >
> > > -----Original Message-----
> > > From: Kyle Galusha [mailto:kgalusha@cisco.com]
> > > Sent: Sunday, January 28, 2001 10:48 AM
> > > To: Bernard Dunn; Jack Reynolds
> > > Subject: RE: ISDN PAP
> > >
> > >
> > > found it. ppp pap sent-username.
> > > Thanks,
> > > Kyle
> > >
> > > At 05:15 AM 1/29/2001 +1100, Bernard Dunn wrote:
> > > >
> > > >
> > > >int dialer0
> > > >
> > > >ppp sent-username xxx password yyy
> > > >ppp authen pap
> > > >
> > > >
> > > >On Sun, 28 Jan 2001, Jack Reynolds wrote:
> > > >
> > > >> Hi,
> > > >>
> > > >> I am using dialer interfaces with ppp auth
> > pap (this command also
> > > appears on
> > > >> bri physical)
> > > >>
> > > >> I made sure that each router had a username
> > for the other router's
> > > dialer
> > > >> remote-name. Both passwords set to cisco.
> > > >>
> > > >>
> > > >> When I do Chap on this, it works fine.
> > Hmmm....
> > > >>
> > > >> R5 (calling router)
> > > >>
> > > >> username R3 password 0 cisco
> > > >>
> > > >> interface BRI0
> > > >> no ip address
> > > >> no ip directed-broadcast
> > > >> encapsulation ppp
> > > >> dialer pool-member 1
> > > >> isdn switch-type basic-ni
> > > >> isdn spid1 0835866201 8358662
> > > >> isdn spid2 0835866401 8358664
> > > >> ppp authentication chap
> > > >> !
> > > >> interface Dialer0
> > > >> ip address 137.10.254.2 255.255.255.252
> > > >> no ip directed-broadcast
> > > >> encapsulation ppp
> > > >> ip ospf interface-retry 0
> > > >> ip ospf demand-circuit
> > > >> dialer remote-name R3
> > > >> dialer idle-timeout 60
> > > >> dialer string 8358661
> > > >> dialer pool 1
> > > >> dialer-group 1
> > > >> ppp authentication chap
> > > >>
> > > >> dialer-list 1 protocol ip permit
> > > >>
> > > >>
> > > >>
> > > >> R3 (called router)
> > > >>
> > > >> username R5 password 0 cisco
> > > >>
> > > >> interface BRI0
> > > >> no ip address
> > > >> no ip directed-broadcast
> > > >> encapsulation ppp
> > > >> dialer pool-member 1
> > > >> isdn switch-type basic-ni
> > > >> isdn spid1 0835866101 8358661
> > > >> isdn spid2 0835866301 8358663
> > > >> ppp authentication chap
> > > >> !
> > > >> interface Dialer0
> > > >> ip address 137.10.254.1 255.255.255.252
> > > >> no ip directed-broadcast
> > > >> ip pim sparse-mode
> > > >> encapsulation ppp
> > > >> ip ospf interface-retry 0
> > > >> ip ospf demand-circuit
> > > >> dialer remote-name R5
> > > >> dialer idle-timeout 60
> > > >> dialer pool 1
> > > >> dialer-group 1
> > > >> ppp authentication chap
> > > >>
> > > >> dialer-list 1 protocol ip permit
> > > >>
> > > >> Now I substitute CHAP for PAP, and here is
> > the debug ppp packet on
> > R5:
> > > >>
> > > >> 13:54:45: BR0:1 LCP: AuthProto PAP
> > (0x0304C023)
> > > >> 13:54:45: BR0:1 LCP: MagicNumber
> > 0x0CF7A525 (0x05060CF7A525)
> > > >> 13:54:45: BR0:1 PPP: I pkt type 0xC021,
> > datagramsize 12
> > > >> 13:54:45: BR0:1 LCP: O CONFNAK [REQsent] id
> > 54 len 9
> > > >> 13:54:45: BR0:1 LCP: AuthProto CHAP
> > (0x0305C22305)
> > > >> 13:54:45: BR0:1 LCP: I CONFREJ [REQsent] id
> > 48 len 8
> > > >> 13:54:45: BR0:1 LCP: AuthProto PAP
> > (0x0304C023)
> > > >> 13:54:45: BR0:1 LCP: O CONFREQ [REQsent] id
> > 49 len 14
> > > >> 13:54
> > > >> :45: BR0:1 PPP: I pkt type 0xC021,
> > datagramsize 18
> > > >> 13:54:45: BR0:1 LCP: AuthProto PAP
> > (0x0304C023)
> > > >> 13:54:45: BR0:1 LCP: MagicNumber
> > 0x03088F46 (0x050603088F46)
> > > >> 13:54:45: BR0:1 LCP: I CONFREQ [REQsent] id
> > 55 len 14
> > > >> 13:54:45: BR0:1 LCP: AuthProto PAP
> > (0x0304C023)
> > > >> 13:54:45: BR0:1 LCP: MagicNumber
> > 0x0CF7A525 (0x05060CF7A525)
> > > >> 13:54:45: BR0:1 PPP: I pkt type 0xC021,
> > datagramsize 12
> > > >> 13:54:45: BR0:1 LCP: O CONFNAK [REQsent] id
> > 55 len 9
> > > >> 13:54:45: BR0:1 LCP: AuthProto CHAP
> > (0x0305C22305)
> > > >>
> >
> === message truncated ===
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:35 GMT-3