From: Andrew Lennon (andrew.lennon@xxxxxxxxxxxxx)
Date: Sat Jun 02 2001 - 14:39:31 GMT-3
Hi all,
Someone was asking about the feasibilty of 1600's for lab type work.
Looking at my 1603 tonight, I realised that out of the 7K NVRAM, I had used
5.5, and that wasn't a particulary large config. After using the "service
compress-config" command, it did go down alot, but it might be something to
be aware of, especially if your router is access-list heavy (2500's have
32K).
I have included my config so you get an idea of the size/space used.
Hope this is of use to you all.
Andy
-----------------------------------
r1603#wr
Building configuration...
Compressed configuration from 5621 bytes to 2983 bytes[OK]
r1603#
r1603#sh run
Building configuration...
Current configuration : 5621 bytes
!
! Last configuration change at 18:04:20 BST Sat Jun 2 2001
! NVRAM config last updated at 18:32:24 BST Sat Jun 2 2001
!
version 12.2
no service single-slot-reload-enable
service nagle
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
no service password-encryption
service compress-config
!
hostname r1603
!
logging rate-limit console 10 except errors
enable secret 5 ?
!
username user password 0 user
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
ip subnet-zero
no ip finger
ip domain-name lennon.nscglobal.com
ip host termsvr 2001 172.17.3.3
ip name-server 192.168.6.252
ip name-server 158.152.1.58
ip name-server 158.152.1.43
ip dhcp excluded-address 192.168.6.244
ip dhcp excluded-address 192.168.6.250
ip dhcp excluded-address 192.168.6.251
ip dhcp excluded-address 192.168.6.252
ip dhcp excluded-address 192.168.6.254
ip dhcp excluded-address 192.168.6.239
!
ip dhcp pool cisco
network 192.168.6.224 255.255.255.224
netbios-node-type h-node
default-router 192.168.6.254
domain-name lennon.nscglobal.com
dns-server 192.168.6.252 158.152.1.43 158.152.1.58
netbios-name-server 192.168.1.209 192.168.1.204
lease 2
!
!
ip vrf customer_A
rd 100:110
no ip dhcp-client network-discovery
ipx routing 0010.7b5a.3681
isdn switch-type basic-net3
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key ? address ?
!
!
crypto ipsec transform-set vpntrans esp-des esp-md5-hmac
!
crypto map vpnmap 10 ipsec-isakmp
set peer 195.217.168.190
set transform-set vpntrans
match address 100
!
!
!
!
interface Loopback0
ip address 190.1.1.1 255.255.255.0
!
interface Loopback1
ip address 190.1.2.1 255.255.255.0
ipx network BADBAD
!
interface Loopback2
ip address 188.100.100.2 255.255.255.0
!
interface Loopback3
ip address 172.30.10.1 255.255.255.0
!
interface Loopback4
ip address 179.200.200.1 255.255.255.0
!
interface Ethernet0
description connected to EthernetLAN_1
ip address 192.168.6.254 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
ntp broadcast
!
interface Ethernet0.1
no ip route-cache
no ip mroute-cache
ipx encapsulation SNAP
ipx network BADBAD1
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface BRI0
description connected to Internet
bandwidth 64
no ip address
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer rotary-group 1
isdn switch-type basic-net3
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
no cdp enable
crypto map vpnmap
!
interface Dialer1
description connected to Internet
bandwidth 64
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip split-horizon
no ip mroute-cache
load-interval 30
dialer in-band
dialer idle-timeout 2147483
dialer string 08440416672
dialer hold-queue 10
dialer-group 1
ppp authentication pap callin
ppp chap hostname andylennon@btinternet.com
ppp chap password ?
ppp pap sent-username lennon password 7 ?
crypto map vpnmap
!
router bgp 200
bgp log-neighbor-changes
network 192.168.6.224 mask 255.255.255.224
redistribute connected
redistribute static
neighbor 192.168.6.225 remote-as 200
neighbor 192.168.6.244 remote-as 100
default-information originate
no auto-summary
!
address-family ipv4 vrf customer_A
no auto-summary
no synchronization
exit-address-family
!
ip nat inside source list 110 interface Dialer1 overload
ip nat inside source static tcp 192.168.6.250 21 interface Dialer1 21
ip nat inside source static tcp 192.168.6.250 20 interface Dialer1 20
ip nat inside source static tcp 192.168.6.251 6697 interface Dialer1 6697
ip nat inside source static tcp 192.168.6.227 6699 interface Dialer1 6699
ip nat inside source static tcp 192.168.6.252 8000 interface Dialer1 8000
ip nat inside source static tcp 192.168.6.253 80 interface Dialer1 80
ip nat inside source static tcp 192.168.6.235 6891 interface Dialer1 6891
ip nat inside source static tcp 192.168.6.252 53 interface Dialer1 53
ip nat inside source static udp 192.168.6.252 53 interface Dialer1 53
ip nat inside source static tcp 192.168.6.252 25 interface Dialer1 25
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
access-list 1 permit 192.168.6.224 0.0.0.31
access-list 100 permit ip 192.168.6.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 172.16.0.0 0.15.255.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.6.0 0.0.0.255 192.168.0.0 0.0.15.255
access-list 110 deny ip 192.168.6.0 0.0.0.255 192.168.0.0 0.0.15.255
access-list 110 deny ip 172.16.0.0 0.15.255.255 192.168.1.0 0.0.0.255
access-list 110 permit ip 192.168.6.0 0.0.0.255 any
access-list 110 permit ip 172.16.0.0 0.15.255.255 any
access-list 180 permit ip host 192.168.6.225 192.168.1.0 0.0.0.255
access-list 700 deny 4000.1111.2222 0000.0000.0000
access-list 700 permit ffff.ffff.ffff 0000.0000.0000
dialer-list 1 protocol ip permit
!
!
ipx sap 4 ccie1 BADBAD.0000.0000.0001 451 4
ipx sap 5 ccie5 BADBAD.0000.0000.0001 451 4
ipx sap 6 ccie6 BADBAD.0000.0000.0001 451 4
ipx sap 7 ccie2 BADBAD.0000.0000.0001 451 3
ipx sap 8 ccie8 BADBAD.0000.0000.0001 451 14
!
!
line con 0
exec-timeout 0 0
password ?
absolute-timeout 300
login
transport input none
line vty 0 4
exec-timeout 0 0
password ?
absolute-timeout 300
login
transport input telnet
escape-character 16
!
ntp clock-period 17180147
ntp source Ethernet0
ntp server 192.5.41.41
ntp server 158.152.1.76 prefer
end
r1603#
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:17 GMT-3