Re: can ppp callback work with ppp multilink?

From: kym blair (kymblair@xxxxxxxxxxx)
Date: Sun Sep 09 2001 - 09:48:16 GMT-3


   
Hiler,

I just set up your config and tried it. PPP Multilink did not interfere;
the ISDN channels went down after the interesting traffic was finished.

I tested it by sending 5000 1000-byte packets from the client, then jumped
over to the server and checked which channels were up.

I tried it again without the "dialer load-threshold 1 outbound" on the
server, and this time only one B-channel opened up; load was 11/255 and
!!!!! was about half the speed.

  Here is my config:

---------------- client -----------------
hostname R1
username R6 password 0 cisco
username something password 0 cisco
isdn switch-type basic-ni
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
ppp callback request
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 17.1.1.1 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name R6
dialer idle-timeout 10
dialer string 8358662
dialer string 8358664
dialer hold-queue 100 timeout 20
dialer-group 1
ppp authentication chap
ppp multilink
access-list 107 deny eigrp any any
access-list 107 deny ospf any any
access-list 107 deny igrp any any
access-list 107 permit ip any any
dialer-list 1 protocol ip list 107
dialer-list 1 protocol ipx permit

---------------- Server -----------------
hostname R6
username R1 password 0 cisco
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
ppp callback accept
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 17.1.1.6 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name R1
dialer callback-secure
dialer idle-timeout 10
dialer string 8358661 class CALLHIMBACK
dialer string 8358663 class CALLHIMBACK
dialer hold-queue 100 timeout 20
dialer load-threshold 1 outbound
dialer-group 1
ppp authentication chap
ppp multilink
!
map-class dialer CALLHIMBACK
dialer callback-server username
access-list 107 deny ospf any any
access-list 107 deny eigrp any any
access-list 107 deny igrp any any
access-list 107 permit ip any any
dialer-list 1 protocol ip list 107
dialer-list 1 protocol ipx permit

HTH. Kym

>From: hiler john <o_hiler@yahoo.com>
>Reply-To: hiler john <o_hiler@yahoo.com>
>To: CCIELAB <CCIELAB@groupstudy.com>
>Subject: can ppp callback work with ppp multilink?
>Date: Sun, 9 Sep 2001 02:17:45 -0700 (PDT)
>
>hi, all
>
>I just tested ppp callback according the example from
>the doc CD, it worked well, but when I added ppp
>multilink, I found the callback didn't work. The
>client called the server and connected, but the server
>didn't disconnect the call and called back. Of course,
>if I added "dialer load-th 1 ou" only in server side,
>the server would place another call on another B
>channel, but it really didn't disconnect the origin
>call from the client. Did anyone test them? can they
>work toghter? If they can, can you give me a sample
>config?
>Below is the config from doc CD, I just changed the
>number and added "ppp multilink".
>
>PPP Callback Server
>interface bri 0
> ip address 7.1.1.7 255.255.255.0
> encapsulation ppp
> dialer callback-secure
> dialer enable-timeout 2
> dialer map ip 7.1.1.8 name atlanta class dial1 1234
> dialer-group 1
> ppp callback accept
> ppp authentication chap
> ppp multilink -----I added
> dialer load-threshold 1 outbound ---I added
>!
>map-class dialer dial1
> dialer callback-server username
>
>PPP Callback Client
>interface bri 0
> ip address 7.1.1.8 255.255.255.0
> encapsulation ppp
> dialer map ip 7.1.1.7 name dallas 4321
> dialer-group 1
> ppp callback request
> ppp authentication chap
> ppp multilink
>
>Best Regards
>Hiler
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:15 GMT-3