From: Sean C. (Upp_and_Upp@xxxxxxxxxxx)
Date: Sat Apr 06 2002 - 22:57:06 GMT-3
Hi Chang,
Sorry about any confusion, I thought your question was meant in general, not
referrencing any particular scenario. But, it is still valid. Please refer
to this link:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c
/ipcprt2/1cdbgp.htm#xtocid2
6. If the local preference is the same, or if no route was originated by the
local router, prefer the route with the shortest autonomous system path.
7. If the autonomous system path length is the same, prefer the route with
the lowest origin code (IGP < EGP < INCOMPLETE).
8. If the origin codes are the same, prefer the route with the lowest Multi
Exit Discriminator (MED) metric attribute.
9. Prefer the external (EBGP) path over the internal (IBGP) path.
HTH,
Sean
----- Original Message -----
From: "ying chang" <ying_c@hotmail.com>
To: <Upp_and_Upp@hotmail.com>; <ccielab@groupstudy.com>
Sent: Saturday, April 06, 2002 2:28 PM
Subject: Re: BGP MED - again
Hi Sean,
Thanks. Please check R3's BGP table. My topology is
-----R1(AS1)-----
| |
R2 R3
|----R6---------| (R2, R3, R6 are in AS236)
As you can see MED is comparision is skipped. as-path will not do anything
for this case, because ebgp route is preferred as we've seen from Peter's
example - as-path comparision come after ebgp-ibgp comparision.
Thanks,
Chang
R1: AS1 (ISP router)
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.1.1.2 110 broadcast
frame-relay map ip 10.1.1.3 120 broadcast
no frame-relay inverse-arp
!
router bgp 1
bgp log-neighbor-changes
network 192.168.1.0
neighbor 10.1.1.2 remote-as 236
neighbor 10.1.1.2 soft-reconfiguration inbound
neighbor 10.1.1.2 route-map set-med1 out
neighbor 10.1.1.3 remote-as 236
neighbor 10.1.1.3 soft-reconfiguration inbound
neighbor 10.1.1.3 route-map set-med2 out
!
!
route-map set-med2 permit 10
set metric 30
set as-path prepend 1 1
!
route-map set-med1 permit 10
set metric 20
!
R2: (AS236, border router 1 to R1)
!
interface Ethernet1
ip address 26.1.1.2 255.255.255.0
!
interface Serial0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.1.1.1 111 broadcast
frame-relay map ip 10.1.1.3 111 broadcast
!
router ospf 100
router-id 26.1.1.2
log-adjacency-changes
passive-interface default
no passive-interface Ethernet1
no passive-interface Serial0
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
bgp router-id 26.1.1.2
bgp always-compare-med
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 soft-reconfiguration inbound
neighbor 26.1.1.6 remote-as 236
neighbor 26.1.1.6 next-hop-self
neighbor 36.1.1.3 remote-as 236
neighbor 36.1.1.3 next-hop-self
neighbor 36.1.1.3 soft-reconfiguration inbound
!
R3: (AS236, border router 2 to R1)
!
interface Ethernet0
ip address 36.1.1.3 255.255.255.0
!
interface Serial0
ip address 10.1.1.3 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.1.1.1 121 broadcast
frame-relay map ip 10.1.1.2 121 broadcast
!
!
router ospf 100
router-id 36.1.1.3
log-adjacency-changes
passive-interface default
no passive-interface Ethernet0
no passive-interface Serial0
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
bgp always-compare-med
bgp log-neighbor-changes
bgp always-compare-med
network 36.1.1.0 mask 255.255.255.0
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 soft-reconfiguration inbound
neighbor 26.1.1.2 remote-as 236
neighbor 26.1.1.2 next-hop-self
neighbor 26.1.1.2 soft-reconfiguration inbound
neighbor 36.1.1.6 remote-as 236
neighbor 36.1.1.6 next-hop-self
neighbor 36.1.1.6 soft-reconfiguration inbound
!
(R6: internal router, IBGP to R2 and R3 only)
!
interface Ethernet0
ip address 26.1.1.6 255.255.255.0
!
interface Ethernet1
ip address 36.1.1.6 255.255.255.0
!
!
router ospf 100
router-id 36.1.1.6
log-adjacency-changes
passive-interface default
no passive-interface Ethernet0
no passive-interface Ethernet1
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 236
no synchronization
bgp router-id 36.1.1.6
bgp always-compare-med
bgp log-neighbor-changes
bgp deterministic-med
network 26.1.1.0 mask 255.255.255.0
network 36.1.1.0 mask 255.255.255.0
neighbor 26.1.1.2 remote-as 236
neighbor 26.1.1.2 soft-reconfiguration inbound
neighbor 36.1.1.3 remote-as 236
neighbor 36.1.1.3 soft-reconfiguration inbound
!
-------------------------------------------------------
BGP tables
-------------------------------------------------------
r1#sib
BGP table version is 25, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* 26.1.1.0/24 10.1.1.2 0 236 i
*> 10.1.1.3 0 236 i
* 36.1.1.0/24 10.1.1.2 0 236 i
*> 10.1.1.3 0 0 236 i
*> 192.168.1.0 0.0.0.0 0 32768 i
r1#
termserv#2
[Resuming connection 2 to r2 ... ]
r2#sib
BGP table version is 4, local router ID is 26.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i26.1.1.0/24 26.1.1.6 0 100 0 i
*>i36.1.1.0/24 26.1.1.6 0 100 0 i
* i 36.1.1.3 0 100 0 i
*> 192.168.1.0 10.1.1.1 20 0 1 i
* i 36.1.1.3 30 100 0 1 1 1 i
r2#
termserv#3
[Resuming connection 3 to r3 ... ]
r3#sib
BGP table version is 5, local router ID is 36.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i26.1.1.0/24 36.1.1.6 0 100 0 i
*> 36.1.1.0/24 0.0.0.0 0 32768 i
* i 36.1.1.6 0 100 0 i
* i192.168.1.0 26.1.1.2 20 100 0 1 i
*> 10.1.1.1 30 0 1 1 1 i
r3#
termserv#6
[Resuming connection 6 to r6 ... ]
r6#sib
BGP table version is 8, local router ID is 36.1.1.6
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 26.1.1.0/24 0.0.0.0 0 32768 i
*> 36.1.1.0/24 0.0.0.0 0 32768 i
* i 36.1.1.3 0 100 0 i
*>i192.168.1.0 26.1.1.2 20 100 0 1 i
* i 36.1.1.3 30 100 0 1 1 1 i
r6#
>From: "Sean C." <Upp_and_Upp@hotmail.com>
>Reply-To: "Sean C." <Upp_and_Upp@hotmail.com>
>To: "ying chang" <ying_c@hotmail.com>, <ccielab@groupstudy.com>
>Subject: Re: BGP MED - again
>Date: Sat, 6 Apr 2002 16:50:54 -0800
>
>Hi Chang,
>
>Concerning your question of how to manipulate routes so the routes will be
>preferred on the R1-R3 link over R2-R3 routes while not being able to
change
>the configs on R1 and R3 (in other words - you can only work on R3) - add a
>route-map on R3 and prepend R3's own AS# to routes being advertised to R2.
>Since shorter AS paths are preferred, the routes will all come in on the
>R1-R3 route which has a shorter AS path. Plus, you don't have to
>manipulate anything on R2 and R1.
>
>Hope this helps,
>Sean
>----- Original Message -----
>From: "ying chang" <ying_c@hotmail.com>
>To: <dan_schaw@yahoo.com>; <jgraun@attbi.com>; <pdostal@724.com>;
><ccielab@groupstudy.com>
>Sent: Saturday, April 06, 2002 12:47 PM
>Subject: RE: BGP MED - again
>
>
>Well, "bgp always compared Med" would not work help in this case as they
>both come from AS1.
>
>There are two web pages are helpful:
>
>http://www.cisco.com/warp/public/459/bgp-med.html
>http://www.cisco.com/warp/public/459/37.html
>
>Here's my question, if we stick on the original problem, which is we are
>trying to tell AS1 to prefer R1-R3 route instead of R2-R3 route, how can we
>do it without changing anything on either R1 or R2? Can it be done? In
>simple term, R1 and R2 are proctor's routers, and you have to work on R3 to
>make R1 and R2 always prefer R1-R3 route.
>
>Thanks,
>Chang
>
>
> >From: Muhamamd Durrani <dan_schaw@yahoo.com>
> >Reply-To: Muhamamd Durrani <dan_schaw@yahoo.com>
> >To: Jason <jgraun@attbi.com>, "'Peter Dostal'" <pdostal@724.com>,
> >ccielab@groupstudy.com
> >Subject: RE: BGP MED
> >Date: Fri, 5 Apr 2002 23:00:57 -0800 (PST)
> >
> >you should use "bgp always compared Med " command to
> >force BGP to compare MED for destination from
> >Different AS systems . By default BGP donot compare
> >MED for same destinations from neighbors from
> >different AS.
> >
> >So R2 must have this command and than verify ur result
> >....
> >
> >Regards,
> >Muhammad
> >
> >
> >--- Jason <jgraun@attbi.com> wrote:
> > > Well iBGP as an Admin distance of 200 while eBGP has
> > > an admin distance
> > > of 20
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com
> > > [mailto:nobody@groupstudy.com] On Behalf Of
> > > Peter Dostal
> > > Sent: Friday, April 05, 2002 6:58 PM
> > > To: ccielab@groupstudy.com
> > > Subject: BGP MED
> > >
> > > I have a problem with BGP path selection process.
> > > Based on the BGP path
> > > selection process I would say that router R2 should
> > > choose iBGP path
> > > over
> > > eBGP (because of lower MED). Any suggestions?
> > > Thanks,
> > >
> > > Peter
> > >
> > >
> > > R1----FrameRelay----R2
> > > | |
> > > ------Ethernet-------
> > > |
> > > R3
> > >
> > > *********************************************
> > > hostname R1
> > > !
> > > interface FastEthernet1/1
> > > ip address 192.168.2.3 255.255.255.0
> > > !
> > > interface Serial1/0
> > > ip address 192.168.1.1 255.255.255.0
> > > encapsulation frame-relay
> > > no keepalive
> > > no fair-queue
> > > frame-relay interface-dlci 100
> > > !
> > > router bgp 2
> > > bgp log-neighbor-changes
> > > neighbor 192.168.1.2 remote-as 2
> > > neighbor 192.168.1.2 next-hop-self
> > > neighbor 192.168.2.1 remote-as 1
> > > neighbor 192.168.2.1 route-map BGP_MAP in
> > > no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > > set local-preference 100
> > >
> > > *********************************************
> > > hostname R2
> > > !
> > > interface FastEthernet0/0
> > > ip address 192.168.2.2 255.255.255.0
> > > !
> > > interface Serial0/0
> > > ip address 192.168.1.2 255.255.255.252
> > > encapsulation frame-relay
> > > no keepalive
> > > no fair-queue
> > > frame-relay interface-dlci 100
> > > !
> > > router bgp 2
> > > bgp log-neighbor-changes
> > > neighbor 192.168.1.1 remote-as 2
> > > neighbor 192.168.1.1 next-hop-self
> > > neighbor 192.168.2.1 remote-as 1
> > > neighbor 192.168.2.1 route-map BGP_MAP in
> > > no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > > set local-preference 100
> > > !
> > > *********************************************
> > > hostname R3
> > > !
> > > interface FastEthernet0/1
> > > ip address 192.168.2.1 255.255.255.0
> > > !
> > > interface Loopback0
> > > ip address 170.2.1.1 255.255.255.240
> > > !
> > > router bgp 1
> > > bgp log-neighbor-changes
> > > network 170.2.1.0 mask 255.255.255.240
> > > neighbor 192.168.2.2 remote-as 2
> > > neighbor 192.168.2.2 route-map BGP_MAP out
> > > neighbor 192.168.2.3 remote-as 2
> > > no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > > set metric 20
> > >
> > > *********************************************
> > > R1#sh ip bgp
> > > BGP table version is 8, local router ID is
> > > 172.10.1.1
> > > Status codes: s suppressed, d damped, h history, *
> > > valid, > best, i -
> > > internal
> > > Origin codes: i - IGP, e - EGP, ? - incomplete
> > >
> > > Network Next Hop Metric
> > > LocPrf Weight Path
> > > *> 170.2.1.0/28 192.168.2.1 0
> > > 100 0 1 i
> > > * i 192.168.1.2 20
> > > 100 0 1 i
> > > *********************************************
> > > R2#sh ip bgp
> > > BGP table version is 8, local router ID is
> > > 192.168.2.2
> > > Status codes: s suppressed, d damped, h history, *
> > > valid, > best, i -
> > > internal
> > > Origin codes: i - IGP, e - EGP, ? - incomplete
> > >
> > > Network Next Hop Metric
> > > LocPrf Weight Path
> > > * i170.2.1.0/28 192.168.1.1 0
> > > 100 0 1 i
> > > *> 192.168.2.1 20
> > > 100 0 1 i
> > > *********************************************
> > >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:58 GMT-3