RE: Aux back to back problem

From: Roberts, Larry (Larry.Roberts@expanets.com)
Date: Wed Sep 18 2002 - 23:14:07 GMT-3


Here are some working configs ( albiet with OSPF demand routing )

Calling ROuter

interface Async65
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer in-band
 dialer pool-member 1
 async default routing
 async dynamic routing
 async mode dedicated

interface Dialer0
 ip address 192.168.12.1 255.255.255.0
 encapsulation ppp
 ip ospf message-digest-key 1 md5 7 094F471A1A0A
 ip ospf demand-circuit
 ip ospf demand-circuit
 dialer pool 1
 dialer idle-timeout 60
 dialer string 1234
 dialer-group 1
 no peer neighbor-route
 no peer default ip address
 no cdp enable
 ppp authentication chap
 ppp chap hostname r1
 ppp chap password 7 05080F1C2243
!
line aux 0
 exec-timeout 0 0
 script dialer myscript
 modem Host
 transport input all
 speed 19200
 flowcontrol hardware

Called ROuter

interface Async65
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer in-band
 dialer pool-member 1
 async default routing
 async dynamic routing
 async mode dedicated
!
interface Dialer0
 ip address 192.168.12.2 255.255.255.0
 encapsulation ppp
 no ip route-cache
 ip ospf message-digest-key 1 md5 7 104D000A0618
 ip ospf demand-circuit
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no peer neighbor-route
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname r2
 ppp chap password 7 01100F175804
!
line aux 0
 exec-timeout 0 0
 script dialer myscript
 modem Dialin
 transport input all
 speed 19200
 flowcontrol hardware

Thanks

Larry
 

-----Original Message-----
From: Le Dinh An [mailto:anld@ispco.com.vn]
Sent: Wednesday, September 18, 2002 8:45 PM
To: syv
Cc: ccielab@groupstudy.com
Subject: Re: Aux back to back problem

'modem host' under line aux 0 of the calling router.

You can have the working configs some days earlier on this list.

An.

syv wrote:

>Hi,
>
>I have 2 router c1751 and c2505 connected back to back
>through the Aux port.
>
>No routing install but it still goes up and down like a yoyo:
>
>Sep 18 15:46:15 PDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface
>Async1, changed state to up Sep 18 15:48:12 PDT: %DIALER-6-UNBIND:
>Interface As1 unbound from profile Di0 Sep 18 15:48:14 PDT:
>%LINK-5-CHANGED: Interface Async1, changed state to reset Sep 18
>15:48:15 PDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1,
>changed state to down Sep 18 15:48:19 PDT: %LINK-3-UPDOWN: Interface
>Async1, changed state to up Sep 18 15:48:19 PDT: %DIALER-6-BIND:
>Interface As1 bound to profile Di0 Sep 18 15:48:22 PDT:
>%LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, changed state
>to up Sep 18 15:50:19 PDT: %DIALER-6-UNBIND: Interface As1 unbound from
>profile Di0 Sep 18 15:50:21 PDT: %LINK-5-CHANGED: Interface Async1,
>changed state to reset Sep 18 15:50:22 PDT: %LINEPROTO-5-UPDOWN: Line
>protocol on Interface Async1, changed state to down Sep 18 15:50:26
>PDT: %LINK-3-UPDOWN: Interface Async1, changed state to up Sep 18
>15:50:26 PDT: %DIALER-6-BIND: Interface As1 bound to profile Di0 Sep 18
>15:50:29 PDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1,
>changed state to up
>
>Any suggestion?
>
>I did debug on async, on ppp and on dialer and do not see anything that
>would call the interface to go up.
>
>The cdp does not [as defined in the dialer-list].
>
>Here are the configs:
>
>The c2505
>
>c2505#s
>Building configuration...
>
>Current configuration : 2142 bytes
>!
>! Last configuration change at 10:05:14 PDT Wed Sep 18 2002
>! NVRAM config last updated at 10:05:16 PDT Wed Sep 18 2002
>!
>version 12.1
>no service single-slot-reload-enable
>service timestamps debug datetime localtime show-timezone service
>timestamps log datetime localtime show-timezone no service
>password-encryption !
>hostname c2505
>!
>logging buffered 16384 debugging
>enable secret 5 $1$Btx/$Kam.aSIufLXVTpi8mx7aC1
>!
>username c1751 password 0 123456
>!
>!
>!
>!
>clock timezone PST -7
>clock summer-time PDT recurring
>ip subnet-zero
>no ip domain-lookup
>!
>chat-script script-null-modem "" ""
>!
>!
>!
>hub ether 0 1
> link-test
> auto-polarity
>!
>hub ether 0 2
> link-test
> auto-polarity
>!
>hub ether 0 3
> link-test
> auto-polarity
>!
>hub ether 0 4
> link-test
> auto-polarity
>!
>hub ether 0 5
> link-test
> auto-polarity
>!
>hub ether 0 6
> link-test
> auto-polarity
>!
>hub ether 0 7
> link-test
> auto-polarity
>!
>hub ether 0 8
> link-test
> auto-polarity
>!
>interface Loopback0
> ip address 152.1.1.2 255.255.255.255
>!
>interface Ethernet0
> no ip address
> shutdown
>!
>interface Serial0
> bandwidth 64
> ip address 152.1.1.6 255.255.255.252
> no fair-queue
> clockrate 64000
>!
>interface Serial1
> bandwidth 64
> ip address 152.1.1.9 255.255.255.252
>!
>interface Async1
> no ip address
> encapsulation ppp
> dialer in-band
> dialer pool-member 1
> async default routing
> async dynamic routing
> async mode dedicated
>!
>interface Dialer0
> ip address 152.1.1.66 255.255.255.192
> encapsulation ppp
> dialer pool 1
> dialer remote-name c1751
> dialer string 111111
> dialer-group 1
>!
>ip classless
>ip http server
>!
>dialer-list 1 protocol ip permit
>!
>alias exec c conf t
>alias exec co cle ip ospf proc
>alias exec cr clea ip rout *
>alias exec r sh ip rout
>alias exec i sh ip int bri
>alias exec s sh run
>alias exec sb sh run | begin
>alias exec w wr mem
>alias exec b sh ip bgp
>alias exec o sh ip ospf
>alias exec cb cle ip bgp *
>!
>line con 0
> exec-timeout 0 0
> logging synchronous
>line aux 0
> exec-timeout 0 0
> script dialer script-null-modem
> logging synchronous
> modem InOut
> transport input all
> flowcontrol hardware
>line vty 0 4
> exec-timeout 0 0
> password cisco
> logging synchronous
> login
>!
>end
>
>The c1751
>
>c1751#s
>Building configuration...
>
>Current configuration : 1926 bytes
>!
>! Last configuration change at 15:37:19 PDT Wed Sep 18 2002
>! NVRAM config last updated at 09:18:18 PDT Wed Sep 18 2002
>!
>version 12.2
>service timestamps debug datetime localtime show-timezone service
>timestamps log datetime localtime show-timezone no service
>password-encryption !
>hostname c1751
>!
>logging buffered 16384 debugging
>enable secret 5 $1$7y.8$s.MeA39GpakvHZe0zWlCp1
>!
>username c2505 password 0 123456
>clock timezone PST -7
>clock summer-time PDT recurring
>ip subnet-zero
>!
>!
>no ip domain lookup
>!
>!
>chat-script script-null-modem "" ""
>!
>!
>!
>interface Loopback0
> ip address 152.1.2.1 255.255.255.255
>!
>interface FastEthernet0/0
> ip address 172.16.1.1 255.255.255.0
> speed auto
>!
>interface Serial0/0
> bandwidth 64
> ip address 152.1.2.5 255.255.255.252
> no fair-queue
> clockrate 64000
>!
>interface Serial0/1
> bandwidth 64
> ip address 152.1.2.129 255.255.255.128
> no fair-queue
>!
>interface Serial1/0
> no ip address
>!
>interface Async5
> no ip address
> encapsulation ppp
> dialer in-band
> dialer pool-member 1
> dialer-group 1
> async default routing
> async dynamic routing
> async mode dedicated
>!
>interface Dialer0
> ip address 152.1.1.65 255.255.255.192
> encapsulation ppp
> dialer pool 1
> dialer remote-name c2505
> dialer string 111111
> dialer-group 1
>!
>ip classless
>no ip http server
>!
>!
>access-list 101 permit ip any host 152.1.1.66
>dialer-list 1 protocol ip permit
>!
>alias exec c conf t
>alias exec co cle ip ospf proc
>alias exec cr cle ip rout *
>alias exec i sh ip int brief
>alias exec r sh ip rout
>alias exec w wr mem
>alias exec s sho run
>alias exec sb show run | begin
>alias exec o sh ip ospf
>alias exec b sh ip bgp
>alias exec cb cle ip bgp *
>!
>line con 0
> exec-timeout 0 0
> logging synchronous
>line aux 0
> exec-timeout 0 0
> script dialer script-null-modem
> logging synchronous
> modem InOut
> transport input all
> flowcontrol hardware
>line vty 0 4
> exec-timeout 0 0
> password 123456
> logging synchronous
> login
>!
>end
>
>
>
>Thanks
>----
>syv@911networks.com



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:43:56 GMT-3