RE: IGRP over ISDN

From: Warner, Thomas S (thomas.s.warner@lmco.com)
Date: Fri Sep 27 2002 - 16:16:44 GMT-3


Dave

It appears that your dialer map statement on the dialed router has the
incorrect IP address. You probably didn't catch it because you were staring
at the config for so long.

interface BRI0/0
 ip address 135.3.14.3 255.255.255.0
 encapsulation ppp
 dialer map ip 139.9.14.5 name r5 broadcast

should be

interface BRI0/0
 ip address 135.3.14.3 255.255.255.0
 encapsulation ppp
 dialer map ip 135.3.14.5 name r5 broadcast

So it makes since that routing updates went over the link from the dialing
router to the dialed router because the dialing router has the correct map
statement.

Debug ip packet on the dialed router should show you some "encapsulation
failed" messages when the router attempts to send traffic back to the
dialing router.

Tom Warner
Lockheed Martin Enterprise Information Systems
Computing and Network Services
email: mailto:thomas.s.warner@lmco.com

-----Original Message-----
From: Dave Stoddard [mailto:dstoddard@thrupoint.net]
Sent: Friday, September 27, 2002 2:55 PM
To: ccielab@groupstudy.com
Subject: IGRP over ISDN

I have the following abbreviated configuration between two routers. IGRP
exclusively is running over the ISDN interface. The complete routing table
is successfully sent between these routers. Yet, I can not ping a single
address across this same bri link, why? I had this working at one time, but
it for some reason it is no longer working. Makes me think I may have a
hardware issue, but this is extremely unlikely. I'm sure I'm missing
something that I must have changed to make something else work that has
caused this to no longer work. Please help. TIA!!!

Dialing router
**************
version 12.1
service password-encryption
!
hostname r5
!
aaa new-model
aaa authentication login default none
aaa authentication ppp default if-needed local
enable secret 5 $1$ClB8$YXcGQA3C9HxeA0DVexDAB1
!
username r3 password 7 094F471A1A0A
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 135.3.5.5 255.255.255.0
!
interface Ethernet0
 backup interface BRI0
 ip address 135.3.10.5 255.255.255.0
!
interface BRI0
 ip address 135.3.14.5 255.255.255.0
 encapsulation ppp
 dialer map ip 135.3.14.3 name r3 broadcast 8358661
 dialer map ip 135.3.14.3 name r3 broadcast 8358663
 dialer load-threshold 64 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication chap callin
 ppp multilink
!
router igrp 100
 network 135.3.0.0
 metric weights 0 1 1 1 0 0
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit

Dialed router
*************
version 12.1
service password-encryption
!
hostname r3
!
aaa new-model
aaa authentication login default none
aaa authentication ppp default if-needed local
enable secret 5 $1$vkdb$cnQCy3Gnw9CAc8dQOQ2gJ0
!
username r5 password 7 045802150C2E
!
isdn switch-type basic-ni
!
!
!
interface Loopback0
 ip address 135.3.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 135.3.20.3 255.255.255.0
 no ip redirects
 ip ospf network broadcast
!
interface Serial0/0
 ip address 135.3.13.3 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface BRI0/0
 ip address 135.3.14.3 255.255.255.0
 encapsulation ppp
 dialer map ip 139.9.14.5 name r5 broadcast
 dialer load-threshold 64 either
 dialer-group 1
 ipx network 14
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 ppp authentication chap
 ppp multilink
!
interface Serial0/1
 ip address 135.3.12.3 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 0518030C345E4B
 ip ospf network non-broadcast
 ipx network 12
 frame-relay map ip 135.3.12.3 301 broadcast
 frame-relay map ip 135.3.12.4 301 broadcast
 frame-relay map ipx 12.0003.0003.0003 301 broadcast
 frame-relay map ip 135.3.12.6 301 broadcast
 frame-relay map ipx 12.0004.0004.0004 301 broadcast
 frame-relay map ipx 12.0006.0006.0006 301 broadcast
 no frame-relay inverse-arp
!
router ospf 100
 router-id 135.3.3.3
 log-adjacency-changes
 area 1 authentication message-digest
 area 1 range 135.3.12.0 255.255.255.0
 area 1 virtual-link 135.3.4.4 authentication message-digest
 area 1 virtual-link 135.3.4.4 message-digest-key 1 md5 7 0017160511490E
 redistribute rip metric 100 subnets
 redistribute igrp 100 metric 100 subnets
 passive-interface Serial0/0
 passive-interface BRI0/0
 network 135.3.3.0 0.0.0.255 area 1
 network 135.3.12.0 0.0.0.7 area 1
 network 135.3.20.0 0.0.0.255 area 33
!
router rip
 redistribute ospf 100 metric 1
 redistribute igrp 100 metric 1
 passive-interface Ethernet0/0
 passive-interface BRI0/0
 passive-interface Serial0/1
 network 135.3.0.0
!
router igrp 100
 redistribute ospf 100 metric 10000 1000 250 1 1500
 redistribute rip metric 10000 1000 250 1 1500
 passive-interface Ethernet0/0
 passive-interface Serial0/0
 passive-interface Serial0/1
 network 135.3.0.0
 metric weights 0 1 1 1 0 0
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:44:05 GMT-3