From: ying c (bf5tgh1@yahoo.com)
Date: Sat Sep 28 2002 - 12:20:14 GMT-3
Not quite the same config as you have because I don't
have end hosts, but it works for me:
R1:
interface Ethernet0
ip address 150.10.10.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 234.5.6.7
ip pim rp-address 150.10.10.1
R2:
r2#sri e0
interface Ethernet0
ip address 150.10.10.1 255.255.255.0
ip pim sparse-mode
ip ospf priority 0
!
interface Serial1.1 multipoint
ip address 172.16.100.5 255.255.255.0
encapsulation frame-relay
ip pim nbma-mode
ip pim sparse-mode
no ip split-horizon
ip ospf priority 255
no arp frame-relay
frame-relay map ip 172.16.100.3 503 broadcast
frame-relay map ip 172.16.100.6 506 broadcast
no frame-relay inverse-arp
ip pim rp-address 150.10.10.1
R3:
!
interface Serial1
ip address 172.16.100.3 255.255.255.0
ip pim sparse-mode
encapsulation frame-relay
ip ospf priority 0
no arp frame-relay
frame-relay map ip 172.16.100.5 305 broadcast
frame-relay map ip 172.16.100.6 305 broadcast
no frame-relay inverse-arp
ip pim rp-address 150.10.10.1
==================================
r3#sh ip ospf int s1
Serial1 is up, line protocol is up
Internet Address 172.16.100.3/24, Area 0
Process ID 100, Router ID 172.16.3.3, Network Type
NON_BROADCAST, Cost: 1562
r2#sh ip ospf int s1.1
Serial1.1 is up, line protocol is up
Internet Address 172.16.100.5/24, Area 0
Process ID 100, Router ID 172.16.5.5, Network Type
NON_BROADCAST, Cost: 1562
r2#sh ip pim rp
Group: 224.0.1.40, RP: 150.10.10.1, v1, next
RP-reachable in 00:00:06
Group: 234.5.6.7, RP: 150.10.10.1, next RP-reachable
in 00:00:05
r2#sh ip mroute
IP Multicast Routing Table
(*, 224.0.1.40), 00:11:07/00:00:00, RP 150.10.10.1,
flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0, Forward/Sparse, 00:11:06/00:02:51
Serial1.1, 172.16.100.3, Forward/Sparse,
00:09:03/00:02:46
(*, 234.5.6.7), 00:11:06/00:02:50, RP 150.10.10.1,
flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0, Forward/Sparse, 00:11:06/00:02:51
r2#
r3#sh ip mroute
IP Multicast Routing Table
(*, 224.0.1.40), 00:10:04/00:00:00, RP 150.10.10.1,
flags: SJPCL
Incoming interface: Serial1, RPF nbr 172.16.100.5
Outgoing interface list: Null
r3#ping 234.5.6.7
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 234.5.6.7, timeout
is 2 seconds:
Reply to request 0 from 150.10.10.10, 68 ms
Reply to request 0 from 150.10.10.10, 92 ms
Reply to request 0 from 150.10.10.10, 80 ms
r3#
--- Adam Crisp <adam.crisp@totalise.co.uk> wrote:
> oh and the RP was statically configured when I did
> the NMBA in 2 below
>
> -----Original Message-----
> From: Adam Crisp [mailto:adam.crisp@totalise.co.uk]
> Sent: 28 September 2002 11:28
> To: Ccielab
> Subject: problem with MBMA and multicast
>
>
> Hi group.
>
> I am having problems with a NON broadcast configured
> framrelay connection
> and PIM
>
>
> HostA---R1-----E-----R2------NMBAFR------R3---Host2
>
> RP is configured and announced at R2 Ethhernet
> (between R1&R2)
>
> 1. If FR is configured as broadcast capable then
> R2&R3 are PIM neibours!
>
> 2. If FR is configured as NON-Bcast then R2 & R2 are
> NOT PIM neibours.
>
> I have tried the "ip pim NMBA" command, but this
> does not seam to work.
> Have I do do anything else? I have searched CO
>
> thanks
>
> Adam
This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:44:06 GMT-3