From: Brian McGahan (brian@cyscoexpert.com)
Date: Wed Dec 18 2002 - 03:15:32 GMT-3
Jason,
The passive interface command in RIP means that you are not
sending updates out that interface. Since the loopback and serial
interface fall within the major network of 153.1.0.0, they are still
included in the RIP database.
'debug ip rip' and look at the output. You will notice that the
serials and loopback are still included in the update, however there are
no updates sent out those interfaces. Then take 'passive-interface
loopback 0' out of the RIP configuration, and check the debug again.
Now you will see a RIP broadcast being sent out that interface.
If you want to prevent the loopback and serial networks from
being advertised out the E0, use a distribute-list. Distribute-list is
a method of applying an access-list or prefix-list to filter routing
updates. The following is an example of what the implementation would
look like in your particular case:
Ip prefix-list RIP deny 153.1.103.0/24
Ip prefix-list RIP deny 153.1.200.0/24
Ip prefix-list RIP deny 153.1.53.64/26
Ip prefix-list RIP permit 0.0.0.0/0 le 32
!
router rip
version 2
passive-interface Ethernet0
passive-interface Loopback0
passive-interface Serial0
passive-interface Serial1
network 153.1.0.0
neighbor 153.1.43.44
distribute-list prefix RIP out Ethernet 0
!
HTH
Brian McGahan, CCIE #8593
Director of Design and Implementation
brian@cyscoexpert.com
CyscoExpert Corporation
Internetwork Consulting & Training
Voice: 847.674.3392
Fax: 847.674.2625
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Jason Cash
> Sent: Tuesday, December 17, 2002 11:18 PM
> To: ccielab@groupstudy.com
> Subject: RIP passive interface (not passive!)
>
> I have configured passive-interfaces on two RIP router's however,
routes
> are still propagating to one another. How can that be?
>
> R5
> |
> | \
> R2 R3
> \ /(E0)
> \ /
> \ /
> / \
> R6 / \
> \ / \(E0)
> R1 R4
>
> R3 and R4 are rip neighbors ('neighbor' statement) via the E0 (which
are
> both passive). However, the loopback and serial interface routes are
> still getting to R4. Here is the config and route table:
>
> R3
> hostname r3
> !
> no ip dhcp-client network-discovery
> clns routing
> !
> interface Loopback0
> ip address 153.1.103.1 255.255.255.0
> !
> interface Ethernet0
> ip address 153.1.43.33 255.255.255.128
> ip rip send version 2
> ip rip receive version 1 2
> no ip route-cache
> no ip mroute-cache
> !
> interface Serial0
> ip address 153.1.200.3 255.255.255.0
> encapsulation frame-relay
> no ip route-cache
> no ip mroute-cache
> !
> interface Serial1
> ip address 153.1.53.67 255.255.255.224
> no ip route-cache
> no ip mroute-cache
> clns router isis
> !
> router ospf 1
> log-adjacency-changes
> network 153.1.200.0 0.0.0.255 area 0
> neighbor 153.1.200.2 priority 100
> neighbor 153.1.200.1 priority 1
> !
> router isis
> net 03.3333.3333.3333.00
> !
> router rip
> version 2
> passive-interface Ethernet0
> passive-interface Loopback0
> passive-interface Serial0
> passive-interface Serial1
> network 153.1.0.0
> neighbor 153.1.43.44
>
> R4
> hostname r4
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> interface Loopback0
> ip address 153.1.104.1 255.255.255.0
> shutdown
> !
> interface Ethernet0
> ip address 153.1.43.44 255.255.255.128
> ip rip send version 2
> ip rip receive version 1 2
> no ip route-cache
> no ip mroute-cache
> no keepalive
> !
> interface Serial0
> ip address 153.1.200.4 255.255.255.0
> encapsulation frame-relay
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> interface Serial1
> no ip address
> no ip route-cache
> no ip mroute-cache
> shutdown
> !
> router rip
> version 2
> passive-interface Ethernet0
> passive-interface Loopback0
> network 153.1.0.0
> neighbor 153.1.43.33
>
> r4# sh ip ro
>
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 153.1.0.0/16 is variably subnetted, 4 subnets, 3 masks
> R 153.1.200.0/24 [120/1] via 153.1.43.33, 00:00:21, Ethernet0
> C 153.1.43.0/25 is directly connected, Ethernet0
> R 153.1.53.64/27 [120/1] via 153.1.43.33, 00:00:21, Ethernet0
> R 153.1.103.0/24 [120/1] via 153.1.43.33, 00:00:21, Ethernet0
>
> Apparently, no routes are getting to R3 from R4 and they area
configured
> the same. Also, when I 'no shut' the Lo0 interface on R4, it then
> propagates that route to R3! Just for fun, here is the 'deb ip rip
> data' when I clear the route table: Following that is the 'sh ip ro'
on
> R3 when I no shut Lo0 in R4
>
> r3#clear ip ro *
> r3#
> 03:43:15: RIP-DB: redist 153.1.0.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:43:15: RIP-DB: redist 153.1.43.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.43.0
> 03:43:15: RIP-DB: adding 153.1.43.0/25 (metric 0) via 0.0.0.0 on
> Ethernet0 to RIP database
> 03:43:15: RIP-DB: redist 153.1.103.0/24(metric 0, last interface
> Loopback0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.103.0
> 03:43:15: RIP-DB: adding 153.1.103.0/24 (metric 0) via 0.0.0.0 on
> Loopback0 to RIP database
> 03:43:15: RIP-DB: redist 153.1.200.0/24(metric 0, last interface
> Serial0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.200.0
> 03:43:15: RIP-DB: adding 153.1.200.0/24 (metric 0) via 0.0.0.0 on
> Serial0 to RIP database
> 03:43:15: RIP-DB: redist 153.1.0.0/16(metric 0, last interface
> Ethernet0) to RIP
> 03:43:15: RIP-DB: redist 153.1.200.0/24(metric 0, last interface
> Serial0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.200.0
> 03:43:15: RIP-DB: adding 153.1.200.0/24 (metric 0) via 0.0.0.0 on
> Serial0 to RIP database
> 03:43:15: RIP-DB: redist 153.1.53.64/27(metric 0, last interface
> Serial1) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.53.64
> 03:43:15: RIP-DB: adding 153.1.53.64/27 (metric 0) via 0.0.0.0 on
> Serial1 to RIP database
> 03:43:15: RIP-DB: clear database
> 03:43:15: RIP-DB: delete 153.1.0.0/16
> 03:43:15: RIP-DB: delete 153.1.43.0/25
> 03:43:15: RIP-DB: delete 153.1.53.64/27
> 03:43:15: RIP-DB: delete 153.1.103.0/24
> 03:43:15: RIP-DB: delete 153.1.200.0/24
> 03:43:15: RIP-DB: Scan IP routing table and redistribute
> 03:43:15: RIP-DB: redist 153.1.200.0/24(metric 0, last interface
> Serial0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.200.0
> 03:43:15: RIP-DB: adding 153.1.200.0/24 (metric 0) via 0.0.0.0 on
> Serial0 to RIP database
> 03:43:15: RIP-DB: add 153.1.200.0/24 (metric 0) via 0.0.0.0 on Serial0
> (donot_age)
> 03:43:15: RIP-DB: Adding new rndb entry 153.1.200.0/24
> 03:43:15: RIP-DB: Created rip ndb summary entry for 153.1.0.0/16
> 03:43:15: RIP-DB: Adding new rndb entry 153.1.0.0/16
> 03:43:15: RIP-DB: redist 153.1.43.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.43.0
> 03:43:15: RIP-DB: adding 153.1.43.0/25 (metric 0) via 0.0.0.0 on
> Ethernet0 to RIP database
> 03:43:15: RIP-DB: add 153.1.43.0/25 (metric 0) via 0.0.0.0 on
Ethernet0
> (donot_age)
> 03:43:15: RIP-DB: Adding new rndb entry 153.1.43.0/25
> 03:43:15: RIP-DB: redist 153.1.53.64/27(metric 0, last interface
> Serial1) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.53.64
> 03:43:15: RIP-DB: adding 153.1.53.64/27 (metric 0) via 0.0.0.0 on
> Serial1 to RIP database
> 03:43:15: RIP-DB: add 153.1.53.64/27 (metric 0) via 0.0.0.0 on Serial1
> (donot_age)
> 03:43:15: RIP-DB: Adding new rndb entry 153.1.53.64/27
> 03:43:15: RIP-DB: redist 153.1.103.0/24(metric 0, last interface
> Loopback0) to RIP
> 03:43:15: RIP-DB: Get redist for network 153.1.103.0
> 03:43:15: RIP-DB: adding 153.1.103.0/24 (metric 0) via 0.0.0.0 on
> Loopback0 to RIP database
> 03:43:15: RIP-DB: add 153.1.103.0/24 (metric 0) via 0.0.0.0 on
Loopback0
> (donot_age)
> 03:43:15: RIP-DB: Adding new rndb entry 153.1.103.0/24
> 03:43:15: RIP-DB: adding 0.0.0.0/0 (metric 4294967295) via 0.0.0.0 on
> Null0 to RIP database
>
> r4#deb ip rip data
> RIP database events debugging is on
> r4#clear ip ro *
> r4#
> 03:44:11: RIP-DB: redist 153.1.0.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:44:11: RIP-DB: redist 153.1.43.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:44:11: RIP-DB: Get redist for network 153.1.43.0
> 03:44:11: RIP-DB: adding 153.1.43.0/25 (metric 0) via 0.0.0.0 on
> Ethernet0 to RIP database
> 03:44:11: RIP-DB: clear database
> 03:44:11: RIP-DB: delete 153.1.0.0/16
> 03:44:11: RIP-DB: delete 153.1.43.0/25
> 03:44:11: RIP-DB: delete 153.1.53.64/27
> 03:44:11: RIP-DB: delete 153.1.103.0/24
> 03:44:11: RIP-DB: delete 153.1.200.0/24
> 03:44:11: RIP-DB: Scan IP routing table and redistribute
> 03:44:11: RIP-DB: redist 153.1.43.0/25(metric 0, last interface
> Ethernet0) to RIP
> 03:44:11: RIP-DB: Get redist for network 153.1.43.0
> 03:44:11: RIP-DB: adding 153.1.43.0/25 (metric 0) via 0.0.0.0 on
> Ethernet0 to RIP database
> 03:44:12: RIP-DB: add 153.1.43.0/25 (metric 0) via 0.0.0.0 on
Ethernet0
> (donot_age)
> 03:44:12: RIP-DB: Adding new rndb entry 153.1.43.0/25
> 03:44:12: RIP-DB: Created rip ndb summary entry for 153.1.0.0/16
> 03:44:12: RIP-DB: Adding new rndb entry 153.1.0.0/16
> 03:44:12: RIP-DB: adding 0.0.0.0/0 (metric 4294967295) via 0.0.0.0 on
> Null0 to RIP database
> 03:44:15: RIP-DB: network_update with 153.1.53.64/27 succeeds
> 03:44:15: RIP-DB: adding 153.1.53.64/27 (metric 1) via 153.1.43.33 on
> Ethernet0 to RIP database
> 03:44:15: RIP-DB: add 153.1.53.64/27 (metric 1) via 153.1.43.33 on
> Ethernet0
> 03:44:15: RIP-DB: Adding new rndb entry 153.1.53.64/27
> 03:44:15: RIP-DB: network_update with 153.1.103.0/24 succeeds
> 03:44:15: RIP-DB: adding 153.1.103.0/24 (metric 1) via 153.1.43.33 on
> Ethernet0 to RIP database
> 03:44:15: RIP-DB: add 153.1.103.0/24 (metric 1) via 153.1.43.33 on
> Ethernet0
> 03:44:15: RIP-DB: Adding new rndb entry 153.1.103.0/24
> 03:44:15: RIP-DB: network_update with 153.1.200.0/24 succeeds
> 03:44:15: RIP-DB: adding 153.1.200.0/24 (metric 1) via 153.1.43.33 on
> Ethernet0 to RIP database
> 03:44:15: RIP-DB: add 153.1.200.0/24 (metric 1) via 153.1.43.33 on
> Ethernet0
> 03:44:15: RIP-DB: Adding new rndb entry 153.1.200.0/24
>
>
> r3#sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 153.1.0.0/16 is variably subnetted, 5 subnets, 3 masks
> C 153.1.200.0/24 is directly connected, Serial0
> C 153.1.43.0/25 is directly connected, Ethernet0
> C 153.1.53.64/27 is directly connected, Serial1
> R 153.1.104.0/24 [120/1] via 153.1.43.44, 00:00:11, Ethernet0
> C 153.1.103.0/24 is directly connected, Loopback0
> 10.0.0.0/24 is subnetted, 1 subnets
> O IA 10.1.1.0 [110/74] via 153.1.200.2, 00:01:09, Serial0
> 11.0.0.0/32 is subnetted, 1 subnets
> O IA 11.1.1.1 [110/65] via 153.1.200.2, 00:01:10, Serial0
> .
.
This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:48 GMT-3