Re: BGP conditional default route advertisement.

From: Bob Sinclair (bsin@cox.net)
Date: Sat Dec 13 2003 - 12:49:21 GMT-3


William,

As you discovered, the access-list mask needs to match the network mask in
the table. I believe that the following access list assumes a host mask:

access-list 7 permit 172.16.107.0

This is the same as:

access-list 7 permit 172.16.107.0 0.0.0.0

Which is also the same as:

access-list 7 permit host 172.16.107.0

As you demonstrated, the route-map with the access-list above is looking for
172.16.107.0/32, which is not in the table,

Hope that helps, but it looks like you figured it out already.

-Bob Sinclair
 CCIE #10427, CISSP, MCSE
 bsinclair@netmasterclass.net
----- Original Message -----
From: "William Chen" <kwchen@netvigator.com>
To: <ccielab@groupstudy.com>
Sent: Saturday, December 13, 2003 1:48 AM
Subject: BGP conditional default route advertisement.

> Dear all,
>
> I am not understand why the BGP conditional advertised default
> route is going to be like that in this router.
>
> ! Here is the BGP setting and the route-map
> router bgp 700
> bgp log-neighbor-changes
> network 7.7.7.0 mask 255.255.255.0
> neighbor 172.16.34.3 remote-as 100
> neighbor 172.16.34.3 default-originate route-map existLo
> neighbor 172.16.34.4 remote-as 100
> neighbor 172.16.34.4 default-originate route-map existLo
> !
> !
> access-list 7 permit 172.16.107.0
> !
> route-map existLo permit 10
> match ip address 7
> !
>
> ! Here is the routing table
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 172.16.0.0/24 is subnetted, 16 subnets
> i L1 172.16.61.0 [115/40] via 172.16.34.4, Ethernet1/0
> i L1 172.16.51.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.36.0 [115/40] via 172.16.34.4, Ethernet1/0
> C 172.16.34.0 is directly connected, Ethernet1/0
> i L1 172.16.25.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.10.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.11.0 [115/30] via 172.16.34.4, Ethernet1/0
> i L1 172.16.120.0 [115/30] via 172.16.34.4, Ethernet1/0
> i L1 172.16.110.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.104.0 [115/10] via 172.16.34.4, Ethernet1/0
> i L1 172.16.105.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.106.0 [115/40] via 172.16.34.4, Ethernet1/0
> C 172.16.107.0 is directly connected, Loopback107
> i L1 172.16.101.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.102.0 [115/20] via 172.16.34.4, Ethernet1/0
> i L1 172.16.103.0 [115/40] via 172.16.34.4, Ethernet1/0
> 7.0.0.0/24 is subnetted, 1 subnets
> C 7.7.7.0 is directly connected, Loopback71
>
> ! BGP default route is not advertised
> FRS#sh ip bgp nei | in def
> Default information originate, default route-map existLo, default not
sent
> Default information originate, default route-map existLo, default not
sent
>
> ! Then I change the access-list 7, and the default route is advertised
> FRS#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> FRS(config)#no access-list 7
> FRS(config)#access-list 7 permit 172.16.107.0 0.0.0.255
> FRS(config)#end
> FRS#sh ip bgp nei | in def
> Default information originate, default route-map existLo, default sent
> Default information originate, default route-map existLo, default sent
> FRS#
>
> Any idea? Here is the "sh ver" output of the router:
> FRS#sh ver
> Cisco Internetwork Operating System Software
> IOS (tm) 3600 Software (C3620-JK8O3S-M), Version 12.2(4)T6, RELEASE
SOFTWARE
> (fc1)
> TAC Support: http://www.cisco.com/tac
> Copyright (c) 1986-2003 by cisco Systems, Inc.
> Compiled Fri 30-May-03 20:23 by eaarmas
> Image text-base: 0x600089A8, data-base: 0x61924000
>
> ROM: System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT
> RELEASE SOFTWARE (fc2)
>
> FRS uptime is 5 hours, 15 minutes
> System returned to ROM by reload
> System restarted at 15:40:09 HKT Fri Dec 12 2003
> System image file is "flash:c3620-jk8o3s-mz.122-4.t6.bin"
>
> cisco 3620 (R4700) processor (revision 0x81) with 61440K/4096K bytes of
> memory.
> Processor board ID 07123827
> R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
> Bridging software.
> X.25 software, Version 3.0.0.
> SuperLAT software (copyright 1990 by Meridian Technology Corp).
> TN3270 Emulation software.
> 1 Ethernet/IEEE 802.3 interface(s)
> 1 Token Ring/IEEE 802.5 interface(s)
> 2 Serial network interface(s)
> 4 Low-speed serial(sync/async) network interface(s)
> DRAM configuration is 32 bits wide with parity disabled.
> 29K bytes of non-volatile configuration memory.
> 16384K bytes of processor board System flash (Read/Write)
>
> Configuration register is 0x2102
>
> Best Regards,
> William Chen
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Jan 03 2004 - 08:25:40 GMT-3