Confusion about default dial peer precedence

From: Mike Dickson (Mike@dicksonnetworks.com)
Date: Thu Feb 10 2005 - 00:27:04 GMT-3


All,

I was playing around with default dial-peers today, and I've ended the
day more confused about the ip precedence set by the default dial-peer
than when I began my experimentation. Hopefully, someone here can shed
some light on this issue.

If an incoming VoIP call does not match a configured dial-peer, the
voice gateway will match the incoming leg against the default dial-peer
(dial-peer 0). According to CCO documentation, the ip precedence
setting for the default dial-peer is 0. However, I've found that if I
complete a call to an FXS port on a router without a matching configured
dial-peer, the return traffic is marked EF, not precedence 0. I even
set the DSCP marking on the calling router to cs4 to make sure that I
wasn't just mirroring the incoming marking, but the return traffic was
still being marked EF. Here are the configs. I'm running 12.2(15)T9 on
both routers.

Called router

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
logging queue-limit 100
enable secret 5 $1$IfjN$PfA4KYGMpQjw.F5cBWOHD.
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip cef accounting per-prefix
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.24.2 255.255.255.0
 ip accounting output-packets
 ip accounting precedence input
 ip accounting precedence output
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial0/2
 no ip address
 shutdown
!
interface Serial0/3
 no ip address
 shutdown
!
router eigrp 24
 network 2.0.0.0
 network 192.168.24.0
 no auto-summary
!
ip http server
ip classless
!
!
!
!
!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 2222 pots
 destination-pattern 2222
 port 1/0/0
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
!

Calling router

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
logging queue-limit 100
enable secret 5 $1$EK7e$SnfgmfaPJw5BYyhVGug0U0
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip cef accounting per-prefix
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.24.5 255.255.255.0
 ip accounting output-packets
 ip accounting precedence input
 ip accounting precedence output
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Serial0/1
 no ip address
 shutdown
!
router eigrp 24
 network 5.0.0.0
 network 192.168.24.0
 no auto-summary
!
ip http server
ip classless
!
!
!
!
!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 5555 pots
 destination-pattern 5555
 port 1/0/0
!
dial-peer voice 2222 voip
 destination-pattern 22..
 session target ipv4:192.168.24.2
 ip qos dscp cs4 media
 no vad
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
!

When I called 2222 from the Calling router, I was able to verify using
show call active voice brief that the incoming dial-peer on the called
router was dial-peer 0. Is the CCO documentation incorrect and the
default marking on dial-peer 0 EF, or is something else marking the
return traffic?

Thanks in advance for any help you can give me.

Mike Dickson
CCIE #12281 (Routing & Switching, Security



This archive was generated by hypermail 2.1.4 : Thu Mar 03 2005 - 08:51:18 GMT-3