Re: RIP v1 and v2 question

From: Gregory W. Posey Jr. (gposey@uaes.org)
Date: Mon Feb 21 2005 - 17:46:01 GMT-3


If you look at the output of "show ip protocol" on R1, the answer should
come to light. By default, when a router runs RIPv1, the interfaces will
"listen" to both v1 & v2 updates.

If someone advertises a v2 update (with subnet mask), then that information
will be received/processed "correctly". If you want R1 to REALLY act as
ONLY RIPv1, then you have to go under the interfaces and type...
"ip rip receive version 1"

HTH

Thank you,
Greg Posey Jr.
CCIE #7981
CCSP, CCSI
M.S. EE

anantha S writes:

> Hi Brian Dennis / Brian McGahan,
>
> I have attached the router configs of R3 (ripv2) and R1 (ripv1). R3's
> connected interface 10.50.31.0/24 is learnt over the link of
> 10.50.13.0/28 which is connected to R1 (ripv1).
>
> My assumption was, Ripv1 router always checks with the connected
> interface mask. and did not expect 10.50.31.0/24 in R1's routing
> table.
>
>
> R3
> ---
>
> R3#
> R3#sh run
> Building configuration...
>
> Current configuration : 2182 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R3
> !
> enable password anik
> !
> ip subnet-zero
> ip cef
> no ip domain-lookup
> !
> !
> key chain anik
> key 1
> key-string anik
> !
> !
> !
> !
> interface Loopback1
> ip address 13.13.13.13 255.255.255.0
> !
> interface Loopback2
> ip address 133.133.133.133 255.255.255.0
> !
> interface Loopback3
> ip address 10.50.13.97 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback31
> ip address 30.30.1.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback32
> ip address 30.30.2.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback33
> ip address 30.30.3.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback34
> ip address 30.30.4.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback35
> ip address 30.30.5.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Loopback36
> ip address 30.30.6.1 255.255.255.0
> ip ospf message-digest-key 1 md5 anik
> ip ospf network point-to-point
> !
> interface Ethernet0
> ip address 10.50.31.3 255.255.255.0
> ip rip authentication mode md5
> ip rip authentication key-chain anik
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0.1 point-to-point
> ip address 10.50.13.3 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> frame-relay interface-dlci 301
> !
> interface Serial0.2 point-to-point
> ip address 10.50.13.23 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> frame-relay interface-dlci 302
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface BRI0
> no ip address
> encapsulation hdlc
> shutdown
> !
> router rip
> version 2
> network 10.0.0.0
> no auto-summary
> !
> ip classless
> ip http server
> !
> access-list 31 permit 10.50.31.0 0.0.0.255
> route-map conn permit 10
> match ip address 31
> !
> !
> line con 0
> exec-timeout 0 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
> R3#
> R3#
> R3#
> R3#sh ip protocols
> Routing Protocol is "rip"
> Sending updates every 30 seconds, next due in 13 seconds
> Invalid after 180 seconds, hold down 180, flushed after 240
> Outgoing update filter list for all interfaces is not set
> Incoming update filter list for all interfaces is not set
> Redistributing: rip
> Default version control: send version 2, receive version 2
> Interface Send Recv Triggered RIP Key-chain
> Ethernet0 2 2 anik
> Loopback3 2 2
> Serial0.1 2 2
> Serial0.2 2 2
> Automatic network summarization is not in effect
> Maximum path: 4
> Routing for Networks:
> 10.0.0.0
> Routing Information Sources:
> Gateway Distance Last Update
> 10.50.13.1 120 20:10:26
> Distance: (default is 120)
>
> R3#
> R3#
> R3#
> R3#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
> C 10.50.13.16/28 is directly connected, Serial0.2
> C 10.50.31.0/24 is directly connected, Ethernet0
> C 10.50.13.0/28 is directly connected, Serial0.1
> C 10.50.13.96/28 is directly connected, Loopback3
> 13.0.0.0/24 is subnetted, 1 subnets
> C 13.13.13.0 is directly connected, Loopback1
> 133.133.0.0/24 is subnetted, 1 subnets
> C 133.133.133.0 is directly connected, Loopback2
> 30.0.0.0/24 is subnetted, 6 subnets
> C 30.30.1.0 is directly connected, Loopback31
> C 30.30.2.0 is directly connected, Loopback32
> C 30.30.3.0 is directly connected, Loopback33
> C 30.30.4.0 is directly connected, Loopback34
> C 30.30.5.0 is directly connected, Loopback35
> C 30.30.6.0 is directly connected, Loopback36
> R3#
>
>
>
> R1:
> ----
> R1#sh run
> Building configuration...
>
> Current configuration : 1279 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> ip subnet-zero
> ip cef
> no ip domain-lookup
> !
> !
> !
> !
> !
> interface Loopback1
> ip address 11.11.11.11 255.255.255.0
> !
> interface Loopback2
> ip address 111.111.111.111 255.255.255.0
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0.2 point-to-point
> ip address 10.50.13.41 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> frame-relay interface-dlci 102
> !
> interface Serial0.3 point-to-point
> ip address 10.50.13.1 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> frame-relay interface-dlci 103
> !
> interface Serial0.5 point-to-point
> ip address 10.50.13.131 255.255.255.224
> frame-relay interface-dlci 105
> !
> interface Serial1
> ip address 10.50.13.81 255.255.255.240
> ip ospf message-digest-key 1 md5 anik
> !
> interface BRI0
> no ip address
> encapsulation hdlc
> shutdown
> !
> router rip
> network 10.0.0.0
> no auto-summary
> !
> ip classless
> ip route 10.10.45.0 255.255.255.0 10.50.13.84
> ip route 10.10.45.0 255.255.255.0 10.50.13.135 200
> ip http server
> !
> !
> line con 0
> exec-timeout 0 0
> line aux 0
> line vty 0 4
> !
> end
>
> R1#
> R1#
> R1#
> R1#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 111.0.0.0/24 is subnetted, 1 subnets
> C 111.111.111.0 is directly connected, Loopback2
> 10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
> C 10.50.13.32/28 is directly connected, Serial0.2
> R 10.50.13.16/28 [120/1] via 10.50.13.3, 00:00:25, Serial0.3
> R 10.50.31.0/24 [120/1] via 10.50.13.3, 00:00:25, Serial0.3
> S 10.10.45.0/24 [1/0] via 10.50.13.84
> C 10.50.13.0/28 is directly connected, Serial0.3
> R 10.50.13.96/28 [120/1] via 10.50.13.3, 00:00:25, Serial0.3
> C 10.50.13.80/28 is directly connected, Serial1
> C 10.50.13.128/27 is directly connected, Serial0.5
> 11.0.0.0/24 is subnetted, 1 subnets
> C 11.11.11.0 is directly connected, Loopback1
> R1#
> R1#
> R1#
> R1#
> R1#
> R1#sh ip proto
> Routing Protocol is "rip"
> Sending updates every 30 seconds, next due in 0 seconds
> Invalid after 180 seconds, hold down 180, flushed after 240
> Outgoing update filter list for all interfaces is not set
> Incoming update filter list for all interfaces is not set
> Redistributing: rip
> Default version control: send version 1, receive any version
> Interface Send Recv Triggered RIP Key-chain
> Serial0.2 1 1 2
> Serial0.3 1 1 2
> Serial0.5 1 1 2
> Serial1 1 1 2
> Automatic network summarization is not in effect
> Maximum path: 4
> Routing for Networks:
> 10.0.0.0
> Routing Information Sources:
> Gateway Distance Last Update
> 10.50.13.3 120 00:00:02
> Gateway Distance Last Update
> 10.50.13.135 120 00:00:15
> Distance: (default is 120)
>
> R1#
> R1#
> R1#
>
>
>
> On Mon, 21 Feb 2005 05:53:57 -0500, Brian Dennis
> <bdennis@internetworkexpert.com> wrote:
>> Since RIPv1 is incapable of carrying the subnet mask information, how
>> could R1 check the "mask" of the 10.50.31.0 route? Post a "show ip
>> route 10.50.31.0" from R1 and see if its not showing up as
>> 10.50.31.0/28.
>>
>> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
>>
>> bdennis@internetworkexpert.com
>> Internetwork Expert, Inc.
>> http://www.InternetworkExpert.com
>> Toll Free: 877-224-8987
>> Direct: 775-745-6404 (Outside the US and Canada)
>>
>> -----Original Message-----
>> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
>> anantha S
>> Sent: Sunday, February 20, 2005 2:15 PM
>> To: Cisco certification
>> Subject: RIP v1 and v2 question
>>
>> Hi all,
>>
>> Question about Rip v1 router accepting a route of different mask from
>> the received interface which has same major network.
>>
>> Topology:
>> ----------------
>> 10.50.13.128/27-------R1 (rip v1)-----10.50.13.0/28------R3 (rip
>> v2)---10.50.31.0/24
>>
>> Should R1 learn 10.50.31.0/24 ?
>>
>> Some reason R1 is learning the route. Can someone give me the reason ?
>> I thought it should check for the major network and mask in R1
>> against 10.50.31.0/24 versus 10.50.13.0/28 and it should reject the
>> update.
>>
>> Below are the snippet i read ((i think its specific to rip version 1))
>> ------------------------------------------------------------------------
>> ----------------------
>>
>> Send Updates
>> ------------------------
>> Before Router 1 sends updates to Router 2, it checks the following:
>> b" Is the subnet information part of the same major net as the
>> interface that is sourcing the update?
>> o No. Router 1 summarizes at the major net boundary and advertises
>> the network.
>> o Yes. Does the network have the same subnet mask as the interface
>> that is sourcing the update?
>> o' No. Router 1 drops the network, and does not advertise it.
>> o' Yes. Router 1 advertises the subnet.
>>
>> Receive Updates
>> ---------------------------
>> When RIP or IGRP receive an update, they perform certain checks before
>> accepting the update and applying the subnet mask. Below is the
>> sequence of events that occurs before Router 2 accepts an update from
>> Router 1:
>> b" Is the subnet received in the update on the same major net as
>> the
>> interface that received the update?
>> o Yes. Router 2 applies the mask of the interface that received
>> the
>> update. If the advertised network has a host bit set in the host
>> portion of the update, Router 2 applies the host mask (/32). In the
>> case of RIP, it continues to advertise the /32 route to the subsequent
>> router, but IGRP does not.
>> o No. Do any subnets of this major net already exist in the
>> routing
>> table, known from interfaces other than the one that received the
>> update? Note that the network in this update should be a major net
>> unless the link between the two routers is an unnumbered link, in
>> which case it is possible for the update to contain subnet
>> information.
>> o' Yes. Router 2 ignores the update.
>> o' No. Router 2 applies a classful mask. If the update came across
>> an
>> unnumbered link and contains subnet information (bits in subnet
>> portion of network are set), then Router 2 applies a host mask. Please
>> refer to Understanding and Configuring the ip unnumbered Command for
>> unnumbered case examples.
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Mar 03 2005 - 08:51:24 GMT-3