From: Tom Lijnse (Tom.Lijnse@globalknowledge.nl)
Date: Thu Apr 07 2005 - 09:32:56 GMT-3
Hi Erick,
It looks like EIGRP is treating this route as a directly connected
route, since it's a static route pointing to an interface.
I quickly configured a similar setup:
interface Ethernet0
ip address 10.10.10.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
ip route 10.2.2.2 255.255.255.255 Null0
And I am getting the same result as you are getting. The static is
advertised via EIGRP even though redistribution of statics is not
enabled:
R2#sh ip route 10.2.2.2
Routing entry for 10.2.2.2/32
Known via "static", distance 1, metric 0 (connected)
Redistributing via eigrp 1
Advertised by eigrp 1
Routing Descriptor Blocks:
* directly connected, via Null0
Route metric is 0, traffic share count is 1
If I configure a static pointing to another interface (Ethernet 0) I get
similar behavior:
R2(config)#ip route 10.3.3.3 255.255.255.255 e0
R2#sh ip route 10.3.3.3
Routing entry for 10.3.3.3/32
Known via "static", distance 1, metric 0 (connected)
Redistributing via eigrp 1
Advertised by eigrp 1
Routing Descriptor Blocks:
* directly connected, via Ethernet0
Route metric is 0, traffic share count is 1
On the other hand, if I configure a static pointing to a next-hop
instead of an interface it is not treated as a connected interface and
therefore not advertised. (As is to be expected):
R2(config)#ip route 10.4.4.4 255.255.255.255 10.10.10.1
R2#sh ip route 10.4.4.4
Routing entry for 10.4.4.4/32
Known via "static", distance 1, metric 0
Routing Descriptor Blocks:
* 10.10.10.1
Route metric is 0, traffic share count is 1
So to come back to your original question: How do you turn this off?
The answer lies in how you configure the network statements under EIGRP.
As you can see I used a blanket 'network 10.0.0.0' statement, which not
only covers my Ethernet interface (10.10.10.2/24), but also the static
routes that I just created. If I reconfigure my network statement to
match only my Ethernet interface IP address it should stop advertising
the statics, since they're not covered by a network statement anymore.
R2(config)#router eigrp 1
R2(config-router)#no network 10.0.0.0
R2(config-router)#network 10.10.10.2 0.0.0.0
R2#sh ip route 10.2.2.2
Routing entry for 10.2.2.2/32
Known via "static", distance 1, metric 0 (connected)
Routing Descriptor Blocks:
* directly connected, via Null0
Route metric is 0, traffic share count is 1
And as you can see now the static to Null 0 is not advertised via EIGRP
any longer.
Regards,
Tom Lijnse
CCIE #11031
Global Knowledge
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Erick Bergquist
Sent: maandag 4 april 2005 7:31
To: Brant I. Stevens; ccielab@groupstudy.com
Subject: Re: Static host routes to null0 automatically insert into EIGRP
I should have been more clear, I am adding a static
host route and it is getting put into EIGRP
automatically. I know static routes are frowned upon
in certain places but this isn't for that certain
place. Just general know-how and why.
Just trying to figure out why it is. Have searched and
looked at various cisco docs.
Thanks.
--- "Brant I. Stevens" <branto@branto.com> wrote:
> If you have an interface summary configured, a null0
> route is added. You
> don't have to worry about that as far as points are
> considered, so long as
> YOU aren't the one typing 'ip route x.x.x.x y.y.y.y
> NULL0'
>
> HTH,
> Brant
>
>
> On 04/03/2005 11:33 PM, "Erick Bergquist"
> <ebergquist@ameritech.net> wrote:
>
> > Hi,
> >
> > Anyone have a idea why a static route for a host
> > address to null0 gets automatically redistributed
> into
> > EIGRP? I have no redist static under the router
> eigrp
> > process and have tried distribute-list and the
> route
> > still shows in the eigrp topology table on the
> same
> > router.
> >
> > Any way to kill this behavior?
> >
> > Thanks, Erick
> >
> >
>
This archive was generated by hypermail 2.1.4 : Tue May 03 2005 - 07:54:54 GMT-3