From: gladston@br.ibm.com
Date: Wed May 25 2005 - 18:01:14 GMT-3
I have notice some inconsistency on IOS related to QoS match under CB.
For example, the following works if configured under physical interface.
But if configured under logical interface, it does not match. Using match access-group and then
using an access-list to match Telnet, it works with subinterfaces.
I have notice this kind of bug on 6500 family. Have you seen this problem?
"Match protocol Telnet" does not match if the service-policy is applyed to logical interface eth0/0.4 but
matches if applyed to physical eth0/0.
To match on logical I changed 'match protocol telnet' to match access-group and then an access-list matching Telnet. This works.
This does not work for logical and works for physical:
class-map match-all Gold
match protocol telnet
class-map match-all Normal
match protocol tftp
class-map match-all http-imp
match protocol http url "*important*"
!
!
policy-map Qos
class Normal
bandwidth 5000
class Gold
bandwidth 4000
!
policy-map Qos
class Normal
bandwidth 5000
class Gold
bandwidth 4000
policy-map Parent
class class-default
shape average 10000000
service-policy Qos
!
interface Ethernet0/0.4
encapsulation dot1Q 4
ip address 142.20.44.4 255.255.255.0
ip access-group 150 in
ip directed-broadcast
ip multicast helper-map broadcast 229.1.1.1 110
service-policy output Parent
rate-limit input access-group 121 512000 64000 96000 conform-action continue exceed-action drop
rate-limit input access-group 122 64000 8000 12000 conform-action transmit exceed-action drop
rate-limit input access-group 123 32000 4000 6000 conform-action transmit exceed-action drop
no ip mroute-cache
ip policy route-map Local-traffic
ntp multicast 229.2.2.2
ipv6 address 2001:1:1:4::4/64
ipv6 address FEC0:2E3D:5B7C:4::4/64
ipv6 nd suppress-ra
Rack2R4#sh policy-map interface e 0/0
Ethernet0/0
Service-policy output: Parent
Class-map: class-default (match-any)
138 packets, 14673 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
10000000/10000000 62500 250000 250000 25 31250
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 0 138 14673 0 0 no
Service-policy : Qos
Class-map: Normal (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol tftp
Queueing
Output Queue: Conversation 265
Bandwidth 5000 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: Gold (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol telnet
Queueing
Output Queue: Conversation 266
Bandwidth 4000 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
This matches Telnet on logical interface:
Rack2R4(config)#class-map match-all Gold
Rack2R4(config-cmap)#no match protocol telnet
Rack2R4(config-cmap)#match access-group 181
Rack2R4#sh policy-map interface e0/0.4
Ethernet0/0.4
Service-policy output: Parent
Class-map: class-default (match-any)
294 packets, 30440 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
10000000/10000000 62500 250000 250000 25 31250
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 0 294 30440 0 0 no
Service-policy : Qos
Class-map: Normal (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol tftp
Queueing
Output Queue: Conversation 265
Bandwidth 5000 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: Gold (match-all)
25 packets, 1399 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 181
Queueing
Output Queue: Conversation 266
Bandwidth 4000 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
This archive was generated by hypermail 2.1.4 : Fri Jun 03 2005 - 10:12:02 GMT-3