From: gladston@br.ibm.com
Date: Thu Jun 23 2005 - 14:49:21 GMT-3
I learned from Cisco docs that max-reserved-bandwidth do not apply to ATM VC.
(http://www.cisco.com/warp/public/121/max_reserved.html)
But that is not what occurs on 12.2T (12.2(15)T14)
The following example is configured with a PVC VBR-nrt where the sustainable rate is 1000.
If using a value higher that 75 on policy-map, IOS complains about the command saying there is just 750 available (75% of 1000).
Now I think that I learned it wrong and Cisco means that (just) the command max-reserved-bandwidth does not work, IOS still only accept 75%, and that can not be changed (well, could not...before the new change on IOS behavior).
Is that right now?
(I was considering that as the command does not apply, it could be reserved as much as 100%, which would be sustained cell rate in this case)
But, to complete the problem, there is this:
"Cisco IOS Software Releases 12.2(6)S, 12.2(6)T, 12.2(4)T2 and 12.2(3) introduce support for the max-reserved-bandwidth command on ATM PVCs on platforms other than the 7500 series (CSCdv06837)."
(http://www.cisco.com/warp/public/121/max_reserved.html)
So it seems things changed again, and max-reserved-bandwidth is supported on ATM PVCs.
So, is this summary correct?
--Before 12.2(4)T2 ATM PVC did not support max-reserved-bandwidth; it is only possibly to use 75% of the bandwidth (which is sustained cell rate for VBR-nrt)
--12.2(4)T2 introduces support for max-reserved-bandwidth on ATM PVC
The following test shows IOS only accepting 75% by default, and the available command max-reserved-band for ATM PVC:
r6#sh queueing interface atm 1/0.69
Interface ATM1/0.69 VC 1/100
Queueing strategy: weighted fair
Output queue: 0/512/64/0 (size/max total/threshold/drops)
Conversations 0/1/64 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 0 kilobits/sec
r6#
r6#sh atm vc
VCD / Peak Avg/Min Burst
Interface Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
1/0 1 0 5 PVC SAAL UBR 155000 UP
1/0 2 0 16 PVC ILMI UBR 155000 UP
1/0.269 140 0 162 SVC SNAP UBR 155000 UP
1/0.69 3 1 100 PVC SNAP VBR 2000 1000 0 UP
1/0.669 137 2 200 PVC SNAP UBR+ 128 64 UP
r6#
r6#b pol
policy-map Telnet
class Telnet
bandwidth 750
r6#
r6#sh run int atm 1/0.69
Building configuration...
Current configuration : 426 bytes
!
interface ATM1/0.69 multipoint
description PVC
ip address 150.100.3.6 255.255.255.0
ip verify unicast reverse-path
pvc 1/100
protocol ipv6 FE80::203:6BFF:FE37:C2A1 broadcast
protocol ipv6 2001:AAAA:BBBB:69::9 broadcast
protocol ip 150.100.3.254 broadcast
vbr-nrt 2000 1000
service-policy output Telnet
!
ipv6 address 2001:AAAA:BBBB:69::6/64
ipv6 rip RIP enable
ipv6 rip RIP summary-address 2001::/16
end
r6(config-if)# policy-map Telnet
r6(config-pmap)# class Telnet
r6(config-pmap-c)# bandwidth 800
I/f ATM1/0.69 VC 1/100 Class Telnet requested bandwidth 800 (kbps) Only 0 (kbps) available
r6(config-pmap-c)#interface ATM1/0.69 multipoint
r6(config-subif)# description PVC
r6(config-subif)# ip address 150.100.3.6 255.255.255.0
r6(config-subif)# ip verify unicast reverse-path
r6(config-subif)# pvc 1/100
r6(config-if-atm-vc)# protocol ipv6 FE80::203:6BFF:FE37:C2A1 broadcast
r6(config-if-atm-vc)# protocol ipv6 2001:AAAA:BBBB:69::9 broadcast
r6(config-if-atm-vc)# protocol ip 150.100.3.254 broadcast
r6(config-if-atm-vc)# vbr-nrt 2000 1000
r6(config-if-atm-vc)# service-policy output Telnet
r6(config-if-atm-vc)#m?
max-reserved-bandwidth
r6(config-if-atm-vc)#ma
r6(config-if-atm-vc)#max-reserved-bandwidth ?
<1-100> Max. reservable bandwidth as % of vc bandwidth
<cr>
r6(config-if-atm-vc)#max-reserved-bandwidth 80 ?
<cr>
r6(config-if-atm-vc)#max-reserved-bandwidth 80
r6(config-if-atm-vc)#
r6(config-if-atm-vc)# policy-map Telnet
r6(config-pmap)# class Telnet
r6(config-pmap-c)# bandwidth 800
This archive was generated by hypermail 2.1.4 : Wed Jul 06 2005 - 14:43:42 GMT-3