RE: Dialer watch with profiles problem

From: Schulz, Dave (DSchulz@dpsciences.com)
Date: Tue Jul 19 2005 - 16:25:08 GMT-3


Thanks to Brian and Scott....this one is resolved. You guys are
awesome!

Interestingly enough....as Brian states, you must have the dialer
idle-timeout configured for "0" at the host end. I also noticed that
you CANNOT leave this off the configuration at the far end,
otherwise....it takes the default of 120 and keeps dropping every two
minutes (not a good thing). Here is the debug at the host when this
happens......

Jul 19 18:26:22.718: Se1/0:9 DDR: idle timeout
Jul 19 18:26:22.718: Se1/0:9 DDR: disconnecting call
Jul 19 18:26:22.718: %ISDN-6-DISCONNECT: Interface Serial1/0:9
disconnected

Also, you need to put the dialer idle-timeout at the remote, so it can
check the line at the time that you specicy.

Another issue came in with the remote end not dropping the
line....(after reviewing the routes....the remote saw the backup route
as being better than the primary route! And therefore, never dropped
the line (22000000 vs. 20000000 metric in EIGRP). To fix this, I added
the offset list to the eigrp configuration (offset-list 0 in 7000000
Dialer23). This was enough to force the primary to truly be the primary
for route when it was active. Added note: I also put in the watch-list
delay for disconnecting the secondary, since you want to make sure that
the primary link is good before dropping the secondary (if there is a
flapping condition). Anyway.....Everything is working perfectly!

Thanks to all!

Just so everyone can benefit from the solution, here are the configs for
the remote and the host end......

REMOTE......

interface BRI0
 bandwidth 128
 no ip address
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 555121210101
 isdn spid2 55512130101
 no fair-queue
 no cdp enable
!
interface Dialer23
 description ISDN backup to HOST
 bandwidth 128
 ip address 10.11.23.2 255.255.255.252
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 dialer pool 1
 dialer idle-timeout 10
 dialer string 7777777
 dialer watch-group 10
 no fair-queue
 no cdp enable
 ppp authentication chap callin
 ppp multilink load-threshold 10 either
!
router eigrp 1
 offset-list 0 in 7000000 Dialer23
 network 10.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
dialer watch-list 10 ip 10.11.255.252 255.255.255.252
dialer watch-list 10 delay disconnect 30

HOST.....
interface Loopback 10
 ip address 10.11.255.252 255.255.255.252

interface Serial1/0:23
 no ip address
 encapsulation ppp
 dialer pool-member 1
 dialer idle-timeout 300
 isdn switch-type primary-4ess
 ppp authentication chap
 ppp multilink
 no clns route-cache
!
interface Dialer23
 description ISDN Backup to REMOTE
 bandwidth 128
 ip address 10.11.23.1 255.255.255.252
 encapsulation ppp
 dialer pool 1
 dialer remote-name REMOTE
 dialer idle-timeout 0
 no cdp enable
 ppp authentication chap
 ppp multilink load-threshold 10 either
 no clns route-cache

I hope that this is a benefit to everytone in their pursuit of the CCIE.

Dave Schulz,
Email: dschulz@dpsciences.com

-----Original Message-----
From: Brian McGahan [mailto:bmcgahan@internetworkexpert.com]
Sent: Tuesday, July 19, 2005 1:19 PM
To: Schulz, Dave; ccielab@groupstudy.com
Subject: RE: Dialer watch with profiles problem

Dave,

        Yes it does check the routing table once the idle timer expires,
but keep in mind that interesting traffic is only locally significant.
Just because the remote end has reset the idle timer doesn't mean it
will affect the receiving end. As for the legacy vs dialer profiles it
should not have any impact.

Brian McGahan, CCIE #8593
bmcgahan@internetworkexpert.com

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/

> -----Original Message-----
> From: Schulz, Dave [mailto:DSchulz@dpsciences.com]
> Sent: Tuesday, July 19, 2005 12:17 PM
> To: Brian McGahan; ccielab@groupstudy.com
> Subject: RE: Dialer watch with profiles problem
>
> Ok. Interesting....why would that be a difference on using the
physical
> interface at the remote side. And, when you use dialer watch, isn't
the
> dialer idle-timeout suppose to just check the line status under dialer
> watch. Was I mistaken?
>
> Dave
>
> -----Original Message-----
> From: Brian McGahan [mailto:bmcgahan@internetworkexpert.com]
> Sent: Tuesday, July 19, 2005 1:15 PM
> To: Schulz, Dave; ccielab@groupstudy.com
> Subject: RE: Dialer watch with profiles problem
>
> Dave,
>
> That is your problem right there. You need to set the idle
> timeout to be zero seconds on the answering side.
>
>
> HTH,
>
> Brian McGahan, CCIE #8593
> bmcgahan@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987 x 705
> Outside US: 775-826-4344 x 705
> 24/7 Support: http://forum.internetworkexpert.com
> Live Chat: http://www.internetworkexpert.com/chat/
>
>
> > -----Original Message-----
> > From: Schulz, Dave [mailto:DSchulz@dpsciences.com]
> > Sent: Tuesday, July 19, 2005 12:13 PM
> > To: Brian McGahan; ccielab@groupstudy.com
> > Subject: RE: Dialer watch with profiles problem
> >
> > Brian -
> >
> > I believe that is the local end that is dropping, since the host did
> not
> > change between the two scenarios. I will try to reconfigure it and
> > recreate the issue....and get the debugs. Here is the configs at
the
> > host end (the answering end).....
> >
> > interface Serial1/0:23
> > no ip address
> > encapsulation ppp
> > dialer pool-member 1
> > dialer idle-timeout 300
> > isdn switch-type primary-4ess
> > ppp authentication chap
> > ppp multilink
> > no clns route-cache
> > !
> > interface Dialer9
> > description ISDN Backup to REMOTE
> > bandwidth 128
> > ip address 10.11.24.1 255.255.255.252 encapsulation ppp dialer
pool
>
> > 1 dialer remote-name REMOTE dialer idle-timeout 60 no cdp enable
> > ppp authentication chap ppp multilink load-threshold 10 either no
> > clns route-cache
> >
> >
> > Dave Schulz
> > Email: dschulz@dpsciences.com
> >
> >
> >
> > -----Original Message-----
> > From: Brian McGahan [mailto:bmcgahan@internetworkexpert.com]
> > Sent: Tuesday, July 19, 2005 12:03 PM
> > To: Schulz, Dave; ccielab@groupstudy.com
> > Subject: RE: Dialer watch with profiles problem
> >
> > Dave,
> >
> > Are you sure it is the local end that is dropping the call?
> > "debug dialer" and "debug dialer packets" on both ends of the link
and
>
> > post your output.
> >
> >
> > HTH,
> >
> > Brian McGahan, CCIE #8593
> > bmcgahan@internetworkexpert.com
> >
> > Internetwork Expert, Inc.
> > http://www.InternetworkExpert.com
> > Toll Free: 877-224-8987 x 705
> > Outside US: 775-826-4344 x 705
> > 24/7 Support: http://forum.internetworkexpert.com
> > Live Chat: http://www.internetworkexpert.com/chat/
> >
> >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
Behalf
> > Of
> > > Schulz, Dave
> > > Sent: Tuesday, July 19, 2005 6:29 AM
> > > To: ccielab@groupstudy.com
> > > Subject: Dialer watch with profiles problem
> > >
> > > I posted a similar question awhile back, but found an interesting
> > issue
> > > working on dialer watch and profiles last night...it appears that
> when
> > you
> > > are
> > > using dialer watch in profiles that you can get somee strange
> results.
> > > The
> > > dialer idle-timeout that is suppose to check the line, actually
> drops
> > the
> > > link
> > > and redials. Then, once it dials the line and comes up....and
then,
> > the
> > > primary comes back, the backup never drops the line and reverts
back
> > to
> > > the
> > > primary.
> > >
> > > However, if you take the same configuration information and move
it
> > under
> > > the
> > > BRI interface and eliminate the profile, everything is happy.
This
> > may be
> > > related to the code of 12.2, but not sure.
> > >
> > > Here is what the configs look like:
> > >
> > > The one that works:
> > >
> > > interface BRI0
> > > bandwidth 128
> > > ip address 10.11.24.2 255.255.255.252 encapsulation ppp no ip
> > > route-cache cef no ip route-cache dialer map ip 10.11.255.252
name
>
> > > HOST broadcast 5551212 dialer watch-group 10 isdn switch-type
> > > basic-ni isdn spid1 55555555550101 isdn spid2 66666666660101 no
> > > fair-queue no cdp enable ppp authentication chap callin ppp
> > > multilink load-threshold 10 either
> > >
> > > dialer watch-list 10 ip 10.11.255.252 255.255.255.252
> > >
> > > Here is the one that did not work cleanly:
> > >
> > > interface BRI0
> > > bandwidth 128
> > > no ip address
> > > encapsulation ppp
> > > no ip route-cache cef
> > > no ip route-cache
> > > dialer pool-member 10
> > > isdn switch-type basic-ni
> > > isdn spid1 55555555550101
> > > isdn spid2 66666666660101
> > > no fair-queue
> > > !
> > > interface Dialer1
> > > bandwidth 128
> > > ip address 10.11.24.2 255.255.255.252 dialer watch-group 10
> > > encapsulation ppp dialer pool 10 dialer remote-name HOST dialer
> > > idle-timeout 60 dialer string 5551212 ppp authentication chap
> > > callin ppp multilink load-threshold 10 either !
> > > dialer watch-list 10 ip 10.11.255.252 255.255.255.252
> > >
> > >
> > > In researching the dialer watch, I did notice that you need to
have
> > the
> > > same
> > > route in the watch list (as the dialer map). However, I cannot
find
> a
> > > command
> > > that is similar to the dialer map (this may relate to the
problem).
> > Also,
> > > I
> > > cannot find a good example with the profile and dialer watch used
> > > together.
> > > Any thoughts or ideas on this weird one?
> > >
> > > Dave
> > >
> > >
> >
>



This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:30 GMT-3