Re: congestion avoidance question

From: Jeff Ryan (jeffryanwn@hotmail.com)
Date: Sun Jul 16 2006 - 11:02:30 ART


Great point Godswill. After I edited the second class, PREC_2, I could see
that the be was set to 0. For the sustained I just used the default of 7936
which I think is ok.

class-map match-any PREC_3_AND_OR_BB1
  match precedence 3
  match access-group 101
class-map match-all PREC_2
  match precedence 2
!
!
policy-map VLAN12_OUT
  class PREC_3_AND_OR_BB1
   bandwidth 128
   random-detect
  class PREC_2
   shape peak 128000 7936 0
!
!
r2#sh policy-map interface ethernet 0/0
<ommitted 1st class>
!
   Class-map: PREC_2 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: precedence 2
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
           128000/128000 992 7936 0 62 992

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

    Class-map: class-default (match-any)
      93 packets, 8961 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
r2#

Thanks,
Jeff

----- Original Message -----
From: "Godswill Oletu" <oletu@inbox.lv>
To: "Victor Cappuccio" <cvictor@protokolgroup.com>
Cc: <ccielab@groupstudy.com>
Sent: Saturday, July 15, 2006 9:57 PM
Subject: Re: congestion avoidance question

> Victor,
>
> The original solution provided by Jeff looks correct, though I think a
> little adjustment need to be done to the shaping aspect of the solution to
> meet the requirement of the question that states:
>
>>Limit all traffic leaving FA 0/0 (VlanX) with Precedence 2 to 128k.
>> DO NOT use policing or rate-limiting and DO NOT use an ACL to match IP
>> Precedence.
>
> Though the shaper is not a good limiting mechanism, the above Task did not
> leave us with much of an option, so one have to tweak the shaper so that,
> it
> can at least have some feel of a limiter. However, the solution provider
> by
> Jeff below did not meet the limiting aspect of the question.
>
>>class-map match-any PREC_3_AND_OR_BB1
>> match precedence 3
>> match access-group 101
>> class-map match-all PREC_2
>> match precedence 2
>> !
>> policy-map VLANX_OUT
> > class PREC_3_AND_OR_BB1
>> bandwidth 128
>> random-detect
>> class PREC_2
>> shape average 128000
>> !
>> interface FastEthernet0/0
>> service-policy output VLANX_OUT
>> !
>> access-list 101 permit ip 1.1.20.0 0.0.0.255 150.100.1.0 0.0.0.255
>
> In order to make sure the shaping mechanism limits the traffic to 128K.
>
>> class PREC_2
>> shape average 128000
>
> The above statement have to be modified so that Be=0.
>
>>shape average 128000
>
> Have the potential to burst above 128K, so setting Be=0 will ensure that
> we
> do not go above 128K.
>
> When I labbed it, I am getting...
>
> Rack1R3#sh policy-map interface fa0/0
> FastEthernet0/0
>
> Service-policy output: VLANX_OUT
>
> Class-map: PREC_3_AND_OR_BB1 (match-any)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: precedence 3
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: access-group 101
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Queueing
> Output Queue: Conversation 265
> Bandwidth 128 (kbps)
> (pkts matched/bytes matched) 0/0
> (depth/total drops/no-buffer drops) 0/0/0
> exponential weight: 9
> mean queue depth: 0
>
> class Transmitted Random drop Tail drop Minimum Maximum
> Mark
> pkts/bytes pkts/bytes pkts/bytes thresh thresh
> prob
> 0 0/0 0/0 0/0 20 40
> 1/10
> 1 0/0 0/0 0/0 22 40
> 1/10
> 2 0/0 0/0 0/0 24 40
> 1/10
> 3 0/0 0/0 0/0 26 40
> 1/10
> 4 0/0 0/0 0/0 28 40
> 1/10
> 5 0/0 0/0 0/0 30 40
> 1/10
> 6 0/0 0/0 0/0 32 40
> 1/10
> 7 0/0 0/0 0/0 34 40
> 1/10
> rsvp 0/0 0/0 0/0 36 40
> 1/10
>
>
> Class-map: PREC_2 (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: precedence 2
> Traffic Shaping
> Target/Average Byte Sustain Excess Interval Increment
> Rate Limit bits/int bits/int (ms) (bytes)
> 128000/128000 1984 7936 7936 62 992
>
> Adapt Queue Packets Bytes Packets Bytes Shaping
> Active Depth Delayed Delayed Active
> - 0 0 0 0 0 no
>
> Class-map: class-default (match-any)
> 1 packets, 60 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> Rack1R3#
>
> You can see that Class 'PREC_2' has Be=7936, it should be set to zero to
> be
> able to limit the traffic to 128K.
>
> HTH
>
>
> Godswill Oletu
> CCIE #16464
>
>
> ----- Original Message -----
> From: "Victor Cappuccio" <cvictor@protokolgroup.com>
> To: "'Godswill Oletu'" <oletu@inbox.lv>
> Cc: <ccielab@groupstudy.com>
> Sent: Saturday, July 15, 2006 8:45 PM
> Subject: RE: congestion avoidance question
>
>
> Hi Godswill so the configuration should look
>
>> > policy-map VLANX_OUT
>> > class PREC_3_AND_OR_BB1
>> > bandwidth 128
>> > random-detect
>> > class PREC_2
>> > bandwidth 128
>> > random-detect
>
> ?
>
> -----Mensaje original-----
> De: Godswill Oletu [mailto:oletu@inbox.lv]
> Enviado el: Sabado, 15 de Julio de 2006 08:15 p.m.
> Para: Kay D; Michael Stout
> CC: cvictor@protokolgroup.com; jeffryanwn@hotmail.com;
> ccielab@groupstudy.com
> Asunto: Re: congestion avoidance question
>
> Guarantee does not necessary call for the use of priority queue. The use
> of
> bandwidth is enough to guarantee your traffic in the event of a
> congestion.
>
> Also the mention of 'minimum' as stated in the original question, will not
> make priority queue look good as an option.
>
>> vlan has a guaranteed minimum bandwidth of 128k
>
> Priority queue have an inbuilt policer and it set a maximum and not a
> minimum transmission rate. Once that maximum is reached other traffic will
> be queued as best effort ie 'no guarantee' and since there is already a
> congestion on the interface to begin with, anything above 128K will not be
> transmitted, this will run contrary to the objective of the question which
> establish a minimum transmission of 128K but leaves the maximum bound
> open.
>
> IMHO, Bandwidth with randon detect should be enough to meet the objective
> of
> the question.
>
> Godswill Oletu
> CCIE #16464
>
>
> ----- Original Message -----
> From: "Kay D" <krsna83@gmail.com>
> To: "Michael Stout" <michaelgstout@hotmail.com>
> Cc: <cvictor@protokolgroup.com>; <jeffryanwn@hotmail.com>;
> <ccielab@groupstudy.com>
> Sent: Saturday, July 15, 2006 5:31 PM
> Subject: Re: congestion avoidance question
>
>
>> Hi,
>> The word "guaranteed" makes us think that we would have to use
>> "priority queue"
>> but the keyword "in case of congestion drop them randomly" makes me
>> think that
>> there is no difference between "priority queue" and " bandwidth "
>> ,,,,as anyways packets would be dropped if there is congestion .
>>
>> The second part of matching the packets with prec value of 2 and
>> assigning a bandwidth , should work with "bandwidth 128" .
>>
>> Please correct me if i am wrong .
>>
>> TIA
>> Kay D
>> Michael Stout wrote:
>> > i agree.
>> >
>> > i think the guaranteed minimum bandwidth of 128k makes a priority queue
> a
>> > requirement.
>> >
>> > --------------------------------------------------------------------
>> >
>> > From: "Victor Cappuccio" <cvictor@protokolgroup.com>
>> > Reply-To: "Victor Cappuccio" <cvictor@protokolgroup.com>
>> > To: "'Jeff Ryan'" <jeffryanwn@hotmail.com>, "'Cisco certification'"
>> > <ccielab@groupstudy.com>
>> > Subject: RE: congestion avoidance question
>> > Date: Sat, 15 Jul 2006 17:01:35 -0400
>> > Hi there Jeff,
>> >
>> > I think that
>> > class PREC_2 is using the priority 128 command.
>> >
>> > BTW I would like to know which workbook you are using, because I'm
>> > looking
>> > for a Workbook Specific to QOS Thanks
>> > Vmctor.-
>> >
>> > -----Mensaje original-----
>> > De: nobody@groupstudy.com [mailto:nobody@groupstudy.com] En nombre de
>> > Jeff
>> > Ryan
>> > Enviado el: Sabado, 15 de Julio de 2006 04:41 p.m.
>> > Para: Cisco certification
>> > Asunto: congestion avoidance question
>> >
>> > All, I'm doing a lab and it is aking me to make sure that all traffic
>> > leaving
>> > FA 0/0 (VlanX) set with Precedence 3 AND/OR traffic from VlanX
>> > destined to
>> > BB1
>> > vlan has a guaranteed minimum bandwidth of 128k. Also, make sure that
>> > in
>> > case
>> > of congestion that these packets get dropped randomly.
>> >
>> > Limit all traffic leaving FA 0/0 (VlanX) with Precedence 2 to 128k.
>> > DO NOT
>> > use
>> > policing or rate-limiting and DO NOT use an ACL to match IP
>> > Precedence.
>> >
>> > Does this look correct? Thanks in advance - Jeff
>> >
>> > --------
>> > R2#
>> > !
>> > ip cef
>> > !
>> > class-map match-any PREC_3_AND_OR_BB1
>> > match precedence 3
>> > match access-group 101
>> > class-map match-all PREC_2
>> > match precedence 2
>> > !
>> > !
>> > policy-map VLANX_OUT
>> > class PREC_3_AND_OR_BB1
>> > bandwidth 128
>> > random-detect
>> > class PREC_2
>> > shape average 128000
>> > !
>> > interface FastEthernet0/0
>> > service-policy output VLANX_OUT
>> > !
>> > access-list 101 permit ip 1.1.20.0 0.0.0.255 150.100.1.0 0.0.0.255
>> > !
>> >
>> >
> _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>> >
>> >
> _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>> >
>> > _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Aug 01 2006 - 07:13:47 ART