From: shank shank (shankshink@yahoo.com)
Date: Sun Jan 28 2007 - 23:23:57 ART
brian,
i tried that but it never worked. then i tried lab 9 V4 task 5.2
according to the solution and it did not work i had a recursive loop again.
any way changed the solution alittle and used a diffierent interface as sourc
to be the a physical interface and then the loop propblem was fixed and a new
problem came up which is i had no pim neighborhood between the two routers
through the tunnel. these are the configs:
r3 tun
interface Tunnel0
ip
address 148.1.13.3 255.255.255.0
ip pim dense-mode
tunnel source Loopback0
tunnel destination 150.1.1.1
end
R1
interface Tunnel0
ip address 148.1.13.1
255.255.255.0
ip pim dense-mode
tunnel source Loopback0
tunnel destination
150.1.3.3
end
these configs cause the routing loop. if i change the source to
a physical interface the pim neighborhood never works. any body can help on
this one!!!
these the complete configs
!
hostname Rack1R1
!
logging
queue-limit 100
enable password 7 00071A150754
!
memory-size iomem 10
ip
subnet-zero
!
!
!
ip multicast-routing
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture
destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 150.1.1.1 255.255.255.0
!
interface Tunnel0
ip address 148.1.13.1
255.255.255.0
ip pim dense-mode
tunnel source Loopback0
tunnel destination
150.1.3.3
!
interface FastEthernet0/0
ip address 148.1.18.1
255.255.255.0
ip pim dense-mode
ip ospf message-digest-key 7 md5 7
14343B382F2B
ip ospf priority 0
ip ospf mtu-ignore
duplex auto
speed auto
!
interface Serial0/0
ip address 148.1.0.1 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
frame-relay map ip 148.1.0.2 102 broadcast
frame-relay map ip 148.1.0.3 102 broadcast
frame-relay map ip 148.1.0.4 104
broadcast
no frame-relay inverse-arp
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
router-id 150.1.1.1
log-adjacency-changes
no
auto-cost
area 168 authentication message-digest
redistribute rip subnets
network 148.1.18.1 0.0.0.0 area 168
network 150.1.1.1 0.0.0.0 area 168
!
router rip
version 2
redistribute ospf 1 metric 1
network 148.1.0.0
network 150.1.0.0
no auto-summary
!
router bgp 100
no synchronization
bgp
router-id 150.1.1.1
bgp log-neighbor-changes
neighbor 148.1.0.2 remote-as
200
neighbor 148.1.0.4 remote-as 400
neighbor 150.1.8.8 remote-as 100
neighbor 150.1.8.8 update-source Loopback0
no auto-summary
!
no ip http
server
ip classless
!
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty
0 4
password 7 05080F1C2243
login
!
!
end
R3 config:
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
!
resource policy
!
memory-size iomem 10
ip subnet-zero
!
!
ip cef
no ip
dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
ip address 148.1.13.3 255.255.255.0
ip pim dense-mode
tunnel source Loopback0
tunnel destination 150.1.1.1
!
interface Loopback0
ip address 150.1.3.3 255.255.255.0
!
interface Ethernet0/0
ip address
148.1.3.3 255.255.255.0
ip hello-interval eigrp 100 4
ip hold-time eigrp 100
12
ip pim dense-mode
ip igmp join-group 224.1.1.1
half-duplex
!
interface
Ethernet0/1
ip address 192.10.7.3 255.255.255.0
full-duplex
!
interface
Serial1/0
no ip address
encapsulation frame-relay
no frame-relay
inverse-arp
!
interface Serial1/0.305 point-to-point
ip address
148.1.0.3 255.255.255.0
ip pim dense-mode
frame-relay interface-dlci 302
!
interface Serial1/1
ip address 148.1.35.3 255.255.255.0
encapsulation
frame-relay
no frame-relay inverse-arp IP 311
no frame-relay inverse-arp IP
312
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no
ip address
shutdown
!
router eigrp 100
redistribute rip metric 1 1 1 1 1
network 148.1.3.3 0.0.0.0
network 148.1.35.3 0.0.0.0
network 150.1.3.3
0.0.0.0
no auto-summary
eigrp router-id 150.1.3.3
!
router rip
version 2
redistribute eigrp 100 metric 1
network 148.1.0.0
network 150.1.0.0
network
192.10.8.0
no auto-summary
!
router bgp 200
no synchronization
bgp
router-id 150.1.3.3
bgp log-neighbor-changes
neighbor 148.1.35.5 remote-as
65057
neighbor 150.1.2.2 remote-as 200
neighbor 150.1.2.2 password CISCO
neighbor 150.1.2.2 update-source Loopback0
neighbor 192.10.1.254 remote-as
254
neighbor 192.10.1.254 password CISCO
neighbor 192.10.7.254 remote-as 254
neighbor 192.10.7.254 password CISCO
neighbor 192.10.8.254 remote-as 254
neighbor 192.10.8.254 password CISCO
no auto-summary
!
no ip http server
ip
classless
!
!
ip mroute 0.0.0.0 0.0.0.0 Tunnel0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging
synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
password cisco
login
!
!
en
and these sh ip routes
R3:
Rack1R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D -
EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external
type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded
static route
Gateway of last resort is not set
B 222.22.2.0/24 [20/0] via
192.10.7.254, 04:24:42
B 220.20.3.0/24 [20/0] via 192.10.7.254, 04:24:42
R
204.12.8.0/24 [120/3] via 148.1.3.9, 00:00:17, Ethernet0/0
B 10.0.0.0/8
[200/0] via 148.1.0.4, 03:38:47
C 192.10.7.0/24 is directly connected,
Ethernet0/1
148.1.0.0/24 is subnetted, 15 subnets
R 148.1.177.0
[120/3] via 148.1.3.9, 00:00:17, Ethernet0/0
D EX 148.1.18.0
[170/2560537856] via 148.1.35.5, 00:00:07, Serial1/1
D 148.1.5.0
[90/20537600] via 148.1.35.5, 05:15:56, Serial1/1
D EX 148.1.4.0
[170/2560537856] via 148.1.35.5, 00:00:08, Serial1/1
D 148.1.7.0
[90/20537856] via 148.1.35.5, 05:15:57, Serial1/1
D EX 148.1.6.0
[170/2560537856] via 148.1.35.5, 00:00:08, Serial1/1
D 148.1.1.0
[90/284160] via 148.1.3.9, 05:15:57, Ethernet0/0
C 148.1.0.0 is directly
connected, Serial1/0.305
C 148.1.3.0 is directly connected, Ethernet0/0
D EX 148.1.13.0 [170/2560537856] via 148.1.35.5, 00:00:08, Serial1/1
D EX
148.1.8.0 [170/2560537856] via 148.1.35.5, 00:00:08, Serial1/1
D
148.1.57.0 [90/20537600] via 148.1.35.5, 05:15:57, Serial1/1
C
148.1.35.0 is directly connected, Serial1/1
D EX 148.1.68.0
[170/2560537856] via 148.1.35.5, 00:00:08, Serial1/1
D 148.1.77.0
[90/20537856] via 148.1.35.5, 05:15:57, Serial1/1
150.1.0.0/24 is
subnetted, 6 subnets
D 150.1.7.0 [90/414720] via 148.1.3.9, 05:15:57,
Ethernet0/0
D 150.1.5.0 [90/440320] via 148.1.3.9, 05:15:58, Ethernet0/0
C 150.1.3.0 is directly connected, Loopback0
R 150.1.2.0 [120/1]
via 148.1.0.2, 00:00:19, Serial1/0.305
D 150.1.10.0 [90/412160] via
148.1.3.9, 05:15:58, Ethernet0/0
D 150.1.9.0 [90/409600] via 148.1.3.9,
05:15:58, Ethernet0/0
B 205.90.31.0/24 [20/0] via 192.10.7.254, 04:24:45
R1
sh ip route
Rack1R1(config-if)#do sh ip route
Codes: C - connected, S -
static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O
- OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF
NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type
2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P
- periodic downloaded static route
Gateway of last resort is not set
B
222.22.2.0/24 [20/0] via 148.1.0.2, 04:52:08
B 220.20.3.0/24 [20/0] via
148.1.0.2, 04:52:08
R 204.12.8.0/24 [120/5] via 148.1.0.3, 00:00:10,
Serial0/0
B 10.0.0.0/8 [20/0] via 148.1.0.4, 03:39:59
148.1.0.0/24 is
subnetted, 15 subnets
R 148.1.177.0 [120/5] via 148.1.0.3, 00:00:11,
Serial0/0
C 148.1.18.0 is directly connected, FastEthernet0/0
R
148.1.5.0 [120/2] via 148.1.0.3, 00:00:11, Serial0/0
R 148.1.4.0 [120/1]
via 148.1.0.4, 00:00:06, Serial0/0
R 148.1.7.0 [120/2] via 148.1.0.3,
00:00:12, Serial0/0
O 148.1.6.0 [110/21] via 148.1.18.8, 02:31:43,
FastEthernet0/0
R 148.1.1.0 [120/2] via 148.1.0.3, 00:00:12, Serial0/0
C
148.1.0.0 is directly connected, Serial0/0
R 148.1.3.0 [120/2] via
148.1.0.3, 00:00:12, Serial0/0
C 148.1.13.0 is directly connected,
Tunnel0
O 148.1.8.0 [110/11] via 148.1.18.8, 02:31:43, FastEthernet0/0
R
148.1.57.0 [120/2] via 148.1.0.3, 00:00:12, Serial0/0
R 148.1.35.0
[120/2] via 148.1.0.3, 00:00:12, Serial0/0
O 148.1.68.0 [110/11] via
148.1.18.8, 02:31:43, FastEthernet0/0
R 148.1.77.0 [120/2] via
148.1.0.3, 00:00:12, Serial0/0
150.1.0.0/16 is variably subnetted, 10
subnets, 2 masks
R 150.1.7.0/24 [120/2] via 148.1.0.3, 00:00:12,
Serial0/0
R 150.1.5.0/24 [120/2] via 148.1.0.3, 00:00:12, Serial0/0
R
150.1.4.0/24 [120/1] via 148.1.0.4, 00:00:07, Serial0/0
R 150.1.3.0/24
[120/2] via 148.1.0.3, 00:00:12, Serial0/0
R 150.1.2.0/24 [120/1] via
148.1.0.2, 00:00:13, Serial0/0
C 150.1.1.0/24 is directly connected,
Loopback0
O 150.1.8.8/32 [110/11] via 148.1.18.8, 02:31:44,
FastEthernet0/0
O 150.1.6.6/32 [110/12] via 148.1.18.8, 02:31:44,
FastEthernet0/0
R 150.1.10.0/24 [120/2] via 148.1.0.3, 00:00:13,
Serial0/0
R 150.1.9.0/24 [120/2] via 148.1.0.3, 00:00:13, Serial0/0
B
205.90.31.0/24 [20/0] via 148.1.0.2, 04:52:10
----- Original Message ----
From: Brian McGahan <bmcgahan@internetworkexpert.com>
To: shank shank
<shankshink@yahoo.com>; Jojo jojo <barrerj1@hotmail.com>
Cc: CCIE Group
<ccielab@groupstudy.com>
Sent: Saturday, January 27, 2007 1:45:50 PM
Subject:
RE: ip add on multicast Tunnels
Yes, you'd simply have to unnumber it to an
interface that is
not the source/destination of the tunnel, and make sure that
the tunnel
destination is not routed out the tunnel.
HTH,
Brian McGahan,
CCIE #8593 (R&S/SP)
bmcgahan@internetworkexpert.com
Internetwork Expert,
Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside
US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live
Chat: http://www.internetworkexpert.com/chat/
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
shank
shank
Sent: Saturday, January 27, 2007 12:01 PM
To: Jojo jojo
Cc: CCIE Group
Subject: Re: ip add on multicast Tunnels
i cant get it to work without the
ips, the ip unnumbered constanly going
through
recursive routing can we do
it without that problem
----- Original
Message ----
From: Jojo jojo
<barrerj1@hotmail.com>
To: shankshink@yahoo.com
Sent: Saturday, January 27,
2007 10:31:48 AM
Subject: RE: ip add on multicast
Tunnels
Shank
if the lab
does not restrict you in using IPs the use then,
If they tell
you not to do
it then dont'
know how to do it both ways and
you'll be fine
hth
JoJo
>From: shank shank <shankshink@yahoo.com>
>Reply-To: shank shank
<shankshink@yahoo.com>
>To: CCIE Group
<ccielab@groupstudy.com>
>Subject: ip
add on multicast Tunnels
>Date: Sat, 27
Jan 2007 01:30:26 -0800 (PST)
>
>All,
> i have been working on IE labs and
the always use ip addresses on the
>tunnels to connect multicast doamins. For
example, lab 9 task 5.2 they used
>ip
>addresses. i have two questions:
>
>is
this ok to use on the exam?? can
we come
>up with any ip addres an put them on
the tun?
>
>can we do the tun
without the
>ip add and avoid the recursive loop
issue?
>
>any ideas or best
practices is
>highly appreciated!!!
>_______________________________________________________________________
______
>_______
>Bored stiff? Loosen up...
>Download and play hundreds of
games for
>free on Yahoo! Games.
>http://games.yahoo.com/games/front
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:57 ART