From: Ridney Laudiano (ridneylaudiano@gmail.com)
Date: Wed Feb 21 2007 - 10:26:33 ART
Are you trying to build a compound frame relay switch? If yes, then maybe
this could help
I have six routers and a frame relay switch with only 4 serial interfaces.
So my frame relay cloud is only limited to four routers (R1-R4) but I wanted
to extend this cloud to the other two routers (R5-R6). Here's what I did.
FRS:S0 - R2:S0
FRS:S1 - R1:S0
FRS:S2 - R3:S0
FRS:S3 - R4:S0
These four routers are ready to participate in the cloud.
Now I'm trying to extend the cloud by using two of those routers (R3 and R4)
to switch frames and extend them to R5 and R6.
R3:S1 - R5:S0
R4:S1 - R6:S0
I used the same serial interface on the FRS S2 and S3 to have a layer3
connection to R3 and R4 and tunnel down there. The sole purpose of using
this method was to conserve the ethernet interface/s specifically for
routing needs.
* FRS *
hostname R7
!
frame-relay switching
!
interface Tunnel73
no ip address
tunnel source 73.0.0.1
tunnel destination 73.0.0.2
!
interface Tunnel74
no ip address
tunnel source 74.0.0.1
tunnel destination 74.0.0.2
!
interface Serial0
description *** R2:S0 ***
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1 102
frame-relay route 203 interface Serial2 302
frame-relay route 204 interface Serial3 402
frame-relay route 205 interface Tunnel73 502
frame-relay route 206 interface Tunnel74 602
!
interface Serial1
description *** R1:S0 ***
no ip address
encapsulation frame-relay
no ip mroute-cache
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0 201
frame-relay route 103 interface Serial2 301
frame-relay route 104 interface Serial3 401
frame-relay route 105 interface Tunnel73 501
frame-relay route 106 interface Tunnel74 601
!
interface Serial2
description *** R3:S0 ***
no ip address
encapsulation frame-relay
no ip mroute-cache
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1 103
frame-relay route 302 interface Serial0 203
frame-relay route 304 interface Serial3 403
frame-relay route 305 interface Tunnel73 503
frame-relay route 306 interface Tunnel74 603
!
interface Serial2.73 multipoint
ip address 73.0.0.1 255.255.255.0
frame-relay map ip 73.0.0.1 703
frame-relay map ip 73.0.0.2 703
!
interface Serial3
description *** R4:S0 ***
no ip address
encapsulation frame-relay
no ip mroute-cache
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 401 interface Serial1 104
frame-relay route 402 interface Serial0 204
frame-relay route 403 interface Serial2 304
frame-relay route 405 interface Tunnel73 504
frame-relay route 406 interface Tunnel74 604
!
interface Serial3.74 multipoint
ip address 74.0.0.1 255.255.255.0
frame-relay map ip 74.0.0.1 704
frame-relay map ip 74.0.0.2 704
* R3 *
hostname R3
!
frame-relay switching
!
interface Tunnel73
no ip address
tunnel source 73.0.0.2
tunnel destination 73.0.0.1
!
interface Tunnel74
no ip address
tunnel source 73.0.0.2
tunnel destination 74.0.0.2
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.703 multipoint
ip address 73.0.0.2 255.255.255.0
frame-relay map ip 73.0.0.1 703
!
interface Serial1
description *** R5:S0 ***
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 501 interface Tunnel73 501
frame-relay route 502 interface Tunnel73 502
frame-relay route 503 interface Tunnel73 503
frame-relay route 504 interface Tunnel73 504
frame-relay route 506 interface Tunnel74 506
!
ip route 74.0.0.2 255.255.255.255 73.0.0.1
!
* R4 *
hostname R4
!
frame-relay switching
!
interface Tunnel73
no ip address
tunnel source 74.0.0.2
tunnel destination 73.0.0.2
!
interface Tunnel74
no ip address
tunnel source 74.0.0.2
tunnel destination 74.0.0.1
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.704 multipoint
ip address 74.0.0.2 255.255.255.0
frame-relay map ip 74.0.0.1 704
frame-relay map ip 74.0.0.2 704
!
interface Serial1
description *** R6:S0 ***
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 601 interface Tunnel74 601
frame-relay route 602 interface Tunnel74 602
frame-relay route 603 interface Tunnel74 603
frame-relay route 604 interface Tunnel74 604
frame-relay route 605 interface Tunnel73 506
!
ip route 73.0.0.2 255.255.255.255 74.0.0.1
!
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Stefan Grey
Sent: Wednesday, February 21, 2007 5:47 AM
To: ccielab@groupstudy.com
Subject: Framerelay switching over ip tunnel!
Hello!
Switching over an IP Tunnel Example
http://www.cisco.com/univercd/cc/td/doc/product/software/ios103/acscg103/782
72.htm
In this link it is described how the Framerelay switching is configured
through ip tunnel. Here are some points which I can't understand. Perhaps
you could help...
1) How it is possible to tunnel the frame-relay frames??? As I have seen
before GRE can tunnel only network layer data but not the frames....
2) Why the routing on the switches is configured only unidirectionally...
say:
frame-relay route 100 interface tunnel 0 200.
but there is no command on the tunnel 0
frame-relay route 200 interface tunnel 100 ??
How can this function??
Any ideas??
3) Is it possible to use the ethernet connection between communication
server and routerC?? Send somehow the frames encapsulated in frame-relay
without actual frame-relay link?? Provider gives just the ethernet link for
framerelay.
Thanks.
This archive was generated by hypermail 2.1.4 : Thu Mar 01 2007 - 07:38:47 ART