Re: multicast very fundamental

From: Bit Gossip (bit.gossip@chello.nl)
Date: Mon Mar 26 2007 - 17:57:31 ART


Bob,
thank you very much for the config; I have uploaded it and I see exactly
the behavior that I was complaining about:
- while r1 (hub) continuously ping 231.1.1.1
- r3 leaves the group sending a prune to 224.0.0.13
- r2 mysteriously hears the prune and sends a join (*,231.1.1.1) to r1
to override it

It is important to notice that r3 should leave the group while there is
traffic for the group because in the cisco pim-sm implementation a
router sends a prune only after receiving the first undesired packet of
the group it wants to leave. Did you execute the test in this condition?

And here is the debug from r2 after r3 leaves the group:

PIM(0): Received v2 Join/Prune on Serial4/0 from 172.16.123.3, not to us
PIM(0): Prune-list: (172.16.101.1/32, 231.1.1.1)
PIM(0): Set join delay timer to 2000 msec for (172.16.101.1/32,
231.1.1.1) on Serial4/0
PIM(0): Prune-list: (*, 231.1.1.1) RP 172.16.101.1
PIM(0): Set join delay timer to 1000 msec for (172.16.101.1/32,
231.1.1.1) on Serial4/0
PIM(0): Building Periodic (*,G) Join / (S,G,RP-bit) Prune message for
231.1.1.1

On Sun, 2007-03-25 at 19:27 -0400, Bob Sinclair wrote:
> Bit Gossip wrote:
> > Bob,
> > do you mind to post your config, at leat for the RP....
> > I tried to relab it with r1 (2651xm) as RP instead of r2 (7200), and also to
> > downgrade to 12.2, but I always have the same result :-(
> >
> Here are my configs. R1 is hub, with R2 and R3 as spokes. Using 3640s
> with (C3640-JS-M), Version 12.4(10a).
>
> R1:
>
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname R1
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> memory-size iomem 5
> !
> !
> ip cef
> no ip domain lookup
> !
> !
> ip multicast-routing
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback101
> ip address 172.16.101.1 255.255.255.0
> ip pim sparse-dense-mode
> ip igmp join-group 231.1.1.1
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> ip ospf network broadcast
> serial restart-delay 0
> no frame-relay inverse-arp
> !
> interface Serial1/0.14 point-to-point
> ip address 172.16.14.1 255.255.255.0
> ip pim sparse-dense-mode
> shutdown
> frame-relay interface-dlci 104
> !
> interface Serial1/0.123 multipoint
> description hub
> ip address 172.16.123.1 255.255.255.0
> ip pim sparse-dense-mode
> ip ospf network point-to-multipoint
> frame-relay map ip 172.16.123.1 102 broadcast
> frame-relay map ip 172.16.123.2 102
> frame-relay map ip 172.16.123.3 103 broadcast
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> router ospf 1
> log-adjacency-changes
> network 172.16.0.0 0.0.255.255 area 0
> !
> ip http server
> !
> !
> ip pim rp-address 172.16.101.1
> !
> snmp-server community public RO
> snmp-server community private RW
> !
> !
> !
> control-plane
> !
> !
> !
> !
> !
> !
> !
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> login
> !
> !
> end
>
> R2:
>
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R2
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> memory-size iomem 5
> !
> !
> ip cef
> no ip domain lookup
> !
> !
> ip multicast-routing
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback102
> ip address 172.16.102.1 255.255.255.0
> ip pim sparse-dense-mode
> ip igmp join-group 231.1.1.1
> !
> interface FastEthernet0/0
> ip address 172.16.26.2 255.255.255.0
> ip pim sparse-dense-mode
> duplex auto
> speed auto
> !
> interface Serial1/0
> ip address 172.16.123.2 255.255.255.0
> ip pim sparse-dense-mode
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> ip ospf priority 0
> serial restart-delay 0
> frame-relay map ip 172.16.123.1 201 broadcast
> frame-relay map ip 172.16.123.2 201
> frame-relay map ip 172.16.123.3 201
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> router ospf 1
> log-adjacency-changes
> network 172.16.0.0 0.0.255.255 area 0
> !
> ip http server
> !
> !
> ip pim rp-address 172.16.101.1
> !
> !
> !
> !
> control-plane
> !
> !
> !
> !
> !
> !
> !
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> login
> !
> !
> end
>
> R3:
>
> version 12.4
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R3
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> memory-size iomem 5
> !
> !
> ip cef
> no ip domain lookup
> !
> !
> ip multicast-routing
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback103
> ip address 172.16.103.1 255.255.255.0
> ip pim sparse-dense-mode
> ip igmp join-group 231.1.1.1
> !
> interface Ethernet0/0
> ip address 172.16.43.3 255.255.255.0
> ip pim sparse-dense-mode
> half-duplex
> !
> interface Ethernet0/1
> ip address 172.16.35.3 255.255.252.0
> ip pim sparse-dense-mode
> half-duplex
> !
> interface Ethernet0/2
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/3
> no ip address
> shutdown
> half-duplex
> !
> interface Serial1/0
> ip address 172.16.123.3 255.255.255.0
> ip pim sparse-dense-mode
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> ip ospf priority 0
> serial restart-delay 0
> frame-relay map ip 172.16.123.1 301 broadcast
> frame-relay map ip 172.16.123.2 301
> frame-relay map ip 172.16.123.3 301
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> router ospf 1
> log-adjacency-changes
> !
> network 172.16.0.0 0.0.255.255 area 0
> !
> ip http server
> !
> !
> ip pim rp-address 172.16.101.1
> !
> !
> !
> !
> control-plane
> !
> !
> !
> !
> !
> !
> !
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> login
> !
> !
> end



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:53 ART