Re: Bridging over frame-relay question

From: Bit Gossip (bit.gossip@chello.nl)
Date: Wed Sep 05 2007 - 07:35:32 ART


Robert,
try enabling crb on R6 and irb on R2 and R5; at that point the ip address
should be assigned to the bvi and not to the bridged interface. My config:

R2 and R5

bridge irb
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map bridge 206 broadcast
 no frame-relay inverse-arp
 bridge-group 1
!
interface BVI1
 ip address 150.50.25.2 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
!
~~~~~~~~~~~~~~~~~~~~~~~~~~
R6

bridge crb
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map bridge 405 broadcast
 bridge-group 1
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map bridge 602 broadcast
 bridge-group 1
!
bridge 1 protocol ieee

~~~~~~~~~~~~~~~~~~~~~~~~~~~

R2#ping 150.50.25.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.25.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/20/36 ms
R2#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 150.50.25.2 - 0000.0c32.0334 ARPA BVI1
Internet 150.50.25.5 6 0000.0c32.ea54 ARPA BVI1

----- Original Message -----
From: <robert.steeneken@getronics.com>
To: <ccielab@groupstudy.com>
Sent: Monday, August 27, 2007 9:17 PM
Subject: Bridging over frame-relay question

> Hello group,
>
> I am been wrestling with bridging over frame-relay,
> This is the test:
>
> 602 206 405 504
> R2-----------R6-------------R5
> s1 s0/2 s0/1 s1
>
> R6
> no ip routing
> !
> interface Serial0/1
> encapsulation frame-relay
> frame-relay map bridge 405 broadcast
> bridge-group 1
> !
> interface Serial0/2
> encapsulation frame-relay
> frame-relay map bridge 602 broadcast
> bridge-group 1
> !
> bridge 1 protocol ieee
>
> R2
> interface Serial1
> ip address 150.50.25.2 255.255.255.0
> encapsulation frame-relay
> no ip route-cache
> frame-relay map ip 150.50.25.5 206 broadcast
> no frame-relay inverse-arp
>
> R5
> interface Serial1
> ip address 150.50.25.5 255.255.255.0
> encapsulation frame-relay
> no ip route-cache
> frame-relay map ip 150.50.25.2 504 broadcast
> no frame-relay inverse-arp
>
> I could not ping between R2 and R5.
> Then I changed the setup to
>
> 602 206 405 504
> R1------R2-----------R6-------------R5-------BB1
> e0 e0 s1 s0/2 s0/1 s1 e0 e0
>
> config of R6 stayed the same and moved the ip's ro R1 en BB1
> now I can ping between the R1 and BB1. Why does it works now?
>
> R2
> no ip routing
> !
> interface Ethernet0
> no ip address
> no ip route-cache
> bridge-group 1
> !
> interface Serial1
> no ip address
> encapsulation frame-relay
> no ip route-cache
> frame-relay map bridge 206 broadcast
> bridge-group 1
> !
> bridge 1 protocol ieee
> !
> R5
> no ip routing
> !
> interface Ethernet0
> no ip address
> no ip route-cache
> bridge-group 1
> !
> interface Serial1
> no ip address
> encapsulation frame-relay
> no ip route-cache
> frame-relay map bridge 504 broadcast
> bridge-group 1
> !
> bridge 1 protocol ieee
> !
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:09 ART