From: Hash Aminu (hashng@gmail.com)
Date: Sun Sep 09 2007 - 17:12:49 ART
Scott,
Thank you for your response, I figured out the reason, I was running all the
IPv4 enabled interfaces in different vrfs and none was on the global
routing table. and the router-id in BGP thinks globally I believe.
After hard coding the Router-id or creating a loopback interface in the
global routing table everything works fine.
Thanks alot
Hash #16818
R5#sh run | b router bgp
router bgp 1
no synchronization
bgp router-id 150.1.26.5
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf 42
neighbor 150.1.142.1 remote-as 1
neighbor 150.1.142.1 activate
no auto-summary
no synchronization
network 150.1.26.5 mask 255.255.255.0
exit-address-family
!
address-family ipv4 vrf 24
neighbor 150.1.124.1 remote-as 1
neighbor 150.1.124.1 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
R5#sh run int lo0
Building configuration...
Current configuration : 86 bytes
!
interface Loopback0
ip vrf forwarding 24
ip address 150.1.26.5 255.255.255.0
end
R5#sh run int e0/0.24
Building configuration...
Current configuration : 142 bytes
!
interface Ethernet0/0.24
encapsulation dot1Q 24
ip vrf forwarding 24
ip address 150.1.124.5 255.255.255.0
no snmp trap link-status
end
R5#sh run int e0/0.42
Building configuration...
Current configuration : 142 bytes
!
interface Ethernet0/0.42
encapsulation dot1Q 42
ip vrf forwarding 42
ip address 150.1.142.5 255.255.255.0
no snmp trap link-status
end
5#sh ip bgp vpnv4 vrf 24 summary
% BGP cannot run because the router-id is not configured
BGP router identifier 0.0.0.0, local AS number 1
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
150.1.124.1 4 1 133 137 0 0 0 00:11:59 Active
R5#
*Mar 1 03:57:23.671: %BGP-4-NORTRID: BGP could not pick a router-id. Please
configure manually.
R5#
R5#
R5#
R5#sh run | beg router bgp 1
router bgp 1
no synchronization
bgp log-neighbor-changes
no auto-summary
-----------------------------------------------------------------------------
R5(config)#int lo 1000
R5(config-if)#ip add 1.1.1.11
*Mar 1 03:59:37.855: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback1000, changed state to u
R5(config-if)#ip add 1.1.1.1 255.255.255.255
R5(config-if)#end
R5#wr
Building configuration...
*Mar 1 03:59:50.987: %SYS-5-CONFIG_I: Configured from console by
console[OK]
R5#sh ip bgp vpnv4 vrf 24 summary
BGP router identifier 1.1.1.1 , local AS number 1
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
150.1.124.1 4 1 133 137 0 0 0 00:14:50 Active
R5#
This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:10 ART