From: shiran guez (shiranp3@gmail.com)
Date: Mon Oct 29 2007 - 12:53:28 ART
if you want to block a route from being redistributed using a route-map then
the best way to go is using a ip prefix list and specify the prefix's you
intrested to block.
ip prefix-list BLOCK permit seq 5 x.x.0.0/16
route-map FILTER deny 10
match ip address prefix BLOCK
!
route-map FILTER permit 20
!
router ospf 1
redistribute eigrp 20 subnets route-map FILTER
On 10/29/07, ccie1101 <ccie1101@gmail.com> wrote:
>
> Joe,
> I don't think you understand my question ..... The null0 carries the
> summary-address network back to ospf. Therefore the x.x.0.0/16 address is
> going back to the OSPF domain which it not needed. This is a conceptual
> question which I want to clarify ....
>
> Can an expert help clarfiy my query if when I redistriute eigrp which
> has a summary-address of the POD with a /16 into OSPF, do I need to use a
> route-map to deny this eigrp summary-address when it goes to OSPF ?
>
> Thanks in advance,
>
> cheers,
> ccie1101.
>
> On 10/27/07, Joseph Saad <joseph.samir.saad@gmail.com> wrote:
> >
> > What do you mean by "Nothing breaks without it"?
> >
> > What is the value of NOT redistributing a Null route and what are you
> > expecting to achieve out of it?
> >
> > What is the outcome on the other routers. My believe is that it has no
> > significance whatsoever as by default the Null0 interface isn't
> > redistributed when you redistribute eigrp 20 into ospf 1.
> >
> > Can I get the full config of router ospf 1 and eigrp 20 along with their
> > neighbors?
> >
> > On 10/26/07, ccie1101 < ccie1101@gmail.com> wrote:
> > >
> > > So do I need to do the following ? It looks like nothing breaks
> without
> > > > it but the summary-address will be all over the POD.
> > > >
> > >
> > > Pls advice,
> > >
> > >
> > >
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------
> > > router ospf 1
> > > redistribute eigrp 20 subnets route-map DENY_NULL
> > > !
> > > route-map DENY_NULL deny 10
> > > match int null0
> > > !
> > > !
> > > route-map DENY_NULL permit 20
> > >
> > >
> > >
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------
> > >
> > > ccie1101.
> > >
> > > On 10/27/07, Joseph Saad <joseph.samir.saad@gmail.com > wrote:
> > > > >
> > > > > My mistake. overlooked the permit 20 line.
> > > > >
> > > > > On 10/26/07, ccie1101 <ccie1101@gmail.com> wrote:
> > > > > >
> > > > > > The connected routes are distributed into ospf as I can see
> those
> > > > > > routes ..... As the route-map does a match on interface null0
> only ..... Why
> > > > > > do you say that the connected routes are not redistributed
> with this set of
> > > > > > commands ?
> > > > > >
> > > > > >
> > > > > > router ospf 1
> > > > > > redistribute eigrp 20 subnets route-map DENY_NULL
> > > > > > !
> > > > > > route-map DENY_NULL deny 10
> > > > > > match int null0
> > > > > > !
> > > > > > !
> > > > > > route-map DENY_NULL permit 20
> > > > > >
> > > > > > Thanks,
> > > > > > ccie1101.
> > > > > >
> > > > > >
> > > > > > On 10/26/07, Joseph Saad <joseph.samir.saad@gmail.com > wrote:
> > > > > > >
> > > > > > > Not only you are stopping redistribution of connected routes,
> > > > > > > but also you are achieving nothing by match int null0 (as this
> match
> > > > > > > connected routes) and you are trying to match a summary route
> that is learnt
> > > > > > > via EIGRP.
> > > > > > >
> > > > > > > You need to match the summary address in a route-map that
> calls
> > > > > > > a prefix list.
> > > > > > >
> > > > > > > ip prefix-list SUMMARY permit X.X.0.0/16
> > > > > > >
> > > > > > > route-map EIGRP2OSPF deny 10
> > > > > > > match ip address prefix-list SUMMARY
> > > > > > >
> > > > > > > route-map EIGRP2OSPF permit 100
> > > > > > >
> > > > > > > router ospf 1
> > > > > > > redistribute eigrp 20 subnet route-map EIGRP2OSPF
> > > > > > > redistribute connected subnets
> > > > > > >
> > > > > > >
> > > > > > > I strongly advise that you watch Internetwork Expert CoD
> > > > > > > Advanced Technology classes. I am however not affiliated with
> them, but have
> > > > > > > seen a considerable difference over a span of 3 months using
> their products.
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > Joseph.
> > > > > > >
> > > > > > > On 10/25/07, ccie1101 < ccie1101@gmail.com > wrote:
> > > > > > >
> > > > > > > > Hi GS,
> > > > > > > > I am redistributing EIGRP into OSPF and since I have
> an
> > > > > > > > eigrp
> > > > > > > > summary-address that goes into OSPF when
> > > > > > > > the redistribution takes place which has the whole network
> of
> > > > > > > > X.X.0.0/16, do
> > > > > > > > I need to do something like this ?
> > > > > > > >
> > > > > > > > router ospf 1
> > > > > > > > redistribute eigrp 20 subnets route-map DENY_NULL
> > > > > > > > !
> > > > > > > > route-map DENY_NULL deny 10
> > > > > > > > match int null0
> > > > > > > > !
> > > > > > > > !
> > > > > > > > route-map DENY_NULL permit 20
> > > > > > > > !
> > > > > > > > !
> > > > > > > > I think this is the way to go around as we should not
> > > > > > > > be seeing the
> > > > > > > > summary-address back into the whole POD.
> > > > > > > >
> > > > > > > > Pls advice,
> > > > > > > >
> > > > > > > > cheers,
> > > > > > > > ccie1101.
> > > > > > > >
> > > > > > > >
> _______________________________________________________________________
> > > > > > > >
> > > > > > > > Subscription information may be found at:
> > > > > > > > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
-- Shiran Guez MCSE CCNP NCE1 http://cciep3.blogspot.com http://www.linkedin.com/in/cciep3
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:19 ART