Re: vrf forwarding applied on physical or virtual-templeate

From: garry baker <baker.garry_at_gmail.com>
Date: Sat, 31 Jul 2010 18:25:57 +0300

well my curiostiy got the best of me, i got it to work with the ip
unnumbered interface my loop67 in my vrf PPPOE and also on the
virtual-template interface:

hostname R6
!
ip vrf PPPOE
 rd 1:1
!
bba-group pppoe global
 virtual-template 1
!
interface Loopback67
 ip vrf forwarding PPPOE
 ip address 67.6.7.6 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
!
interface Virtual-Template1
 ip vrf forwarding PPPOE
 ip unnumbered Loopback67
 ip ospf mtu-ignore
 peer default ip address pool R7
!
router ospf 1000 vrf PPPOE
 log-adjacency-changes
 network 67.6.7.6 0.0.0.0 area 0
!
ip local pool R7 67.6.7.7

hostname R1
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1000 area 0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address negotiated
 encapsulation ppp
 ip ospf mtu-ignore
 ip ospf 1000 area 0
 dialer pool 1
 dialer-group 1
!
router ospf 1000
 router-id 1.1.1.1
 log-adjacency-changes

R6#sh ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Vi1.1 1000 0 0.0.0.0/0 1 P2P 1/1
Vt1 1000 0 0.0.0.0/0 1 DOWN 0/0
Lo67 1000 0 67.6.7.6/24 1 LOOP 0/0

R6#sh ip route vrf PPPOE
     1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 67.6.7.7, 00:02:33, Virtual-Access1.1
     67.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 67.6.7.0/24 is directly connected, Loopback67
C 67.6.7.7/32 is directly connected, Virtual-Access1.1

R1#sh ip route
     1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
     67.0.0.0/32 is subnetted, 2 subnets
C 67.6.7.6 is directly connected, Dialer1
C 67.6.7.7 is directly connected, Dialer1

R1#sh ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Di1 1000 0 67.6.7.7/32 1785 P2P 1/1
Lo1 1000 0 1.1.1.1/32 1 LOOP 0/0

R6#ping vrf PPPOE 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/64 ms

R6#traceroute vrf PPPOE 1.1.1.1

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 67.6.7.7 84 msec 68 msec *

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Sat, Jul 31, 2010 at 5:56 PM, garry baker <baker.garry_at_gmail.com> wrote:
> is the IP of the Unnumbered f0/1 in the VRF?
>
> you can manually set the ospf router-id to correct that if need be i would
> imagine
>
> interesting combo of vrf with pppoe i will have to lab it up...
>
> you have a simple diagram of your setup or sh run from the client/server?
>
>
> --
> Garry L. Baker
>
> "There is no 'patch' for stupidity." - www.sqlsecurity.com
>
>
>
> On Sat, Jul 31, 2010 at 5:51 PM, Prakash Kalsaria <
> kalsaria.prakash_at_gmail.com> wrote:
>
>> My Virtual templeate has an IP from Unnumbered fa0/1
>>
>> but when i apply the vrf for on Virtual-template than i am able to form a
>> adjacency
>> even after i put mtu 1492 on dialer
>>
>> when i start the OSPF process
>> it say cannot take a router-id for the OSPF proccess
>>
>> is it we have to apply it on both Virtual-templeate and physical Interface
>>
>> Thanks for the Reply
>>
>> Regards,
>> http://prakashkalsaria.wordpress.com
>>
>>
>>
>> On Sat, Jul 31, 2010 at 8:14 PM, Muzammil Malick <malickmuz_at_gmail.com
>> >wrote:
>>
>> > Prakash
>> >
>> > You are using a virtual-template therefore you would need to configure
>> > your ip address on the virtual-template.
>> > This tells me that you would need to configure the virtual -template
>> > to forward the VRF otherwise the ip address
>> > will not be routable in the VRF you require.
>> >
>> >
>> > On 31 July 2010 15:18, Prakash Kalsaria <kalsaria.prakash_at_gmail.com>
>> > wrote:
>> > > I have a router which is a server for the PPPoE session and is a PE
>> for a
>> > > VPN site
>> > > now were do i apply a Vrf forwarding on physical interface /
>> > > virtual-templeate
>> > > or on Both
>> > >
>> > >
>> > > http://prakashkalsaria.wordpress.com
>> > >
>> > >
>> > > Blogs and organic groups at http://www.ccie.net
>> > >
>> > >
>> _______________________________________________________________________
>> > > Subscription information may be found at:
>> > > http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Sat Jul 31 2010 - 18:25:57 ART

This archive was generated by hypermail 2.2.0 : Sun Aug 01 2010 - 19:19:15 ART