Re: Internet Traffic load balancing

From: garry baker <baker.garry_at_gmail.com>
Date: Tue, 3 May 2011 09:23:11 +0300

a limited test with the IOS and 3 routers using ip sla:

applied service-policy to see the traffic load balance over interface s0/0
and f0/0, with the ip sla icmp-echo tests running every 5 seconds, of course
this only shows icmp with the same packet sizes, not like an IMIX from and
IXIA or a Smartbits...

R2#sh policy-map interface
 FastEthernet0/0
  Service-policy output: f00
    Class-map: class-default (match-any)
      1812 packets, 144610 bytes
      30 second offered rate 1000 bps, drop rate 0 bps
      Match: any
 Serial0/0
  Service-policy output: s00
    Class-map: class-default (match-any)
      546 packets, 37306 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any

R2#sh policy-map interface
 FastEthernet0/0
  Service-policy output: f00
    Class-map: class-default (match-any)
      2578 packets, 205581 bytes
      30 second offered rate 1000 bps, drop rate 0 bps
      Match: any
 Serial0/0
  Service-policy output: s00
    Class-map: class-default (match-any)
      775 packets, 52825 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any

R2#sh ip route
Gateway of last resort is 169.254.2.3 to network 0.0.0.0
     169.254.0.0/32 is subnetted, 10 subnets
S 169.254.1.6 [1/0] via 10.0.0.3
S 169.254.1.7 [1/0] via 10.0.0.3
S 169.254.1.4 [1/0] via 10.0.0.3
S 169.254.1.5 [1/0] via 10.0.0.3
S 169.254.2.1 [1/0] via 20.0.0.3
S 169.254.1.2 [1/0] via 10.0.0.3
S 169.254.1.3 [1/0] via 10.0.0.3
S 169.254.2.3 [1/0] via 20.0.0.3
S 169.254.2.2 [1/0] via 20.0.0.3
S 169.254.1.1 [1/0] via 10.0.0.3
     20.0.0.0/24 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Serial0/0
     129.53.0.0/24 is subnetted, 1 subnets
C 129.53.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 169.254.2.3
               [1/0] via 169.254.2.2
               [1/0] via 169.254.2.1
               [1/0] via 169.254.1.7
               [1/0] via 169.254.1.6
               [1/0] via 169.254.1.5
               [1/0] via 169.254.1.4
               [1/0] via 169.254.1.3
               [1/0] via 169.254.1.2
               [1/0] via 169.254.1.1

hostname R1
!
interface FastEthernet0/1
 ip address 129.53.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 129.53.1.2
!
ip sla 1
 icmp-echo 1.1.1.1
 frequency 5
!
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 2.2.2.2
 frequency 5
ip sla schedule 2 life forever start-time now
ip sla 3
 icmp-echo 3.3.3.3
 frequency 5
ip sla schedule 3 life forever start-time now
ip sla 4
 icmp-echo 4.4.4.4
 frequency 5
ip sla schedule 4 life forever start-time now
ip sla 5
 icmp-echo 5.5.5.5
 frequency 5
ip sla schedule 5 life forever start-time now
ip sla 6
 icmp-echo 6.6.6.6
 frequency 5
ip sla schedule 6 life forever start-time now
ip sla 7
 icmp-echo 7.7.7.7
 frequency 5
ip sla schedule 7 life forever start-time now
ip sla 8
 icmp-echo 8.8.8.8
 frequency 5
ip sla schedule 8 life forever start-time now
ip sla 9
 icmp-echo 9.9.9.9
 frequency 5
ip sla schedule 9 life forever start-time now
ip sla 10
 icmp-echo 10.10.10.10
 frequency 5
ip sla schedule 10 life forever start-time now

hostname R2
!
policy-map f00
 class class-default
policy-map s00
 class class-default
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 load-interval 30
 service-policy output f00
!
interface Serial0/0
 ip address 20.0.0.2 255.255.255.0
 load-interval 30
 service-policy output s00
!
interface FastEthernet0/1
 ip address 129.53.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 169.254.1.1
ip route 0.0.0.0 0.0.0.0 169.254.1.2
ip route 0.0.0.0 0.0.0.0 169.254.1.3
ip route 0.0.0.0 0.0.0.0 169.254.1.4
ip route 0.0.0.0 0.0.0.0 169.254.1.5
ip route 0.0.0.0 0.0.0.0 169.254.1.6
ip route 0.0.0.0 0.0.0.0 169.254.1.7
ip route 0.0.0.0 0.0.0.0 169.254.2.1
ip route 0.0.0.0 0.0.0.0 169.254.2.2
ip route 0.0.0.0 0.0.0.0 169.254.2.3
ip route 169.254.1.1 255.255.255.255 10.0.0.3
ip route 169.254.1.2 255.255.255.255 10.0.0.3
ip route 169.254.1.3 255.255.255.255 10.0.0.3
ip route 169.254.1.4 255.255.255.255 10.0.0.3
ip route 169.254.1.5 255.255.255.255 10.0.0.3
ip route 169.254.1.6 255.255.255.255 10.0.0.3
ip route 169.254.1.7 255.255.255.255 10.0.0.3
ip route 169.254.2.1 255.255.255.255 20.0.0.3
ip route 169.254.2.2 255.255.255.255 20.0.0.3
ip route 169.254.2.3 255.255.255.255 20.0.0.3

hostname R3
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.0
!
interface Loopback4
 ip address 4.4.4.4 255.255.255.0
!
interface Loopback5
 ip address 5.5.5.5 255.255.255.0
!
interface Loopback6
 ip address 6.6.6.6 255.255.255.0
!
interface Loopback7
 ip address 7.7.7.7 255.255.255.0
!
interface Loopback8
 ip address 8.8.8.8 255.255.255.0
!
interface Loopback9
 ip address 9.9.9.9 255.255.255.0
!
interface Loopback10
 ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.3 255.255.255.0
!
interface Serial0/0
 ip address 20.0.0.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.0.0.2
ip route 0.0.0.0 0.0.0.0 20.0.0.2

 --
Garry L. Baker

"With sufficient thrust, pigs fly just fine..." - RFC 1925

On Tue, May 3, 2011 at 4:55 AM, ALL From_NJ <all.from.nj_at_gmail.com> wrote:

> Well ... maybe some tap water ... we shall see. Awww what the heck, you
> are
> a great guy, ok, unflavored water it is ...
>
>
> .
>
> On Mon, May 2, 2011 at 9:53 PM, Marko Milivojevic <markom_at_ipexpert.com
> >wrote:
>
> > Can I opt for unflavored water? ;-)
> >
> >
> > --
> > Marko Milivojevic - CCIE #18427
> > Senior Technical Instructor - IPexpert
> >
> > Free CCIE Training: <http://bit.ly/vLecture>http://bit.ly/vLecture
> >
> > Mailto: <markom_at_ipexpert.com>markom_at_ipexpert.com
> > Telephone: +1.810.326.1444
> > Community: <http://www.ipexpert.com/communities>
> > http://www.ipexpert.com/communities
> >
> > :: Sent from my phone. Apologies for errors and brevity. ::
> >
> >
> > On May 2, 2011, at 18:48, ALL From_NJ <all.from.nj_at_gmail.com> wrote:
> >
> > When we get to Vegas, I will buy / bring you a free Coors or Bud at the
> > booth at the solutions center.
> >
> > LOL
> >
> >
> > .
> > On Mon, May 2, 2011 at 9:41 PM, Marko Milivojevic < <markom_at_ipexpert.com
> >
> > markom_at_ipexpert.com> wrote:
> >
> >> I'd love to, but that, once again, requires packet generator, which I
> >> don't have readily available. Someone else needs to volunteer for this
> >> one :-). I'll keep on slamming the CEF solution, as I'm curious about
> >> it. PBR... nah, never scales - it's a band-aid.
> >>
> >> --
> >> Marko Milivojevic - CCIE #18427
> >> Senior Technical Instructor - IPexpert
> >>
> >> FREE CCIE training: <http://bit.ly/vLecture>http://bit.ly/vLecture
> >>
> >> Mailto: <markom_at_ipexpert.com>markom_at_ipexpert.com
> >> Telephone: +1.810.326.1444
> >> Web: <http://www.ipexpert.com/>http://www.ipexpert.com/
> >>
> >> On Mon, May 2, 2011 at 18:39, ALL From_NJ < <all.from.nj_at_gmail.com>
> >> all.from.nj_at_gmail.com> wrote:
> >> > Very cool to see this idea, wow ... I would not have thought of that.
> >> >
> >> > I would however, be more inclined to consider a different solution.
> The
> >> CEF
> >> > load balancing idea is fine if all flows are equal ... but ... as we
> >> know,
> >> > no all flows are equal. And ... nothing will come out even or exactly
> >> > 70/30% either ... so we should probably aim for 'close-enough'.
> >> >
> >> > What type of traffic are we talking about?
> >> >
> >> > What about the millisecond bursts, what if a 'heavy' flow goes out the
> >> > slower link? What if a voice and or video etc ... also happen to also
> >> go
> >> > out the slow link? Which flow gets dropped, delayed, shaped ... etc
> >> ....?
> >> > Is this ok?
> >> >
> >> > Since this clever solution only considers L3, you may be causing more
> >> harm
> >> > at various times in your network.
> >> >
> >> > From a production standpoint, this would be hard to pinpoint and
> tshoot
> >> > since the nature of flows is changing ... good today, bad tomorrow,
> good
> >> at
> >> > 10 am, but not at 1PM when people come back from lunch ... etc ...
> >> >
> >> > Might be best to look at PBR or another solution which can distribute
> >> the
> >> > load based on packet sizes or protocol. Maybe send just http or
> >> something
> >> > similar out the slow link, and send everything else out the larger
> >> > connection.
> >> >
> >> > Also, whatever solution is chosen, how will you know if you have
> >> configured
> >> > the right solution? You will need to monitor the interfaces / queues
> >> for
> >> > drops etc ...
> >> >
> >> > I am learning from you all! Nice to see this thread!!! You guys
> >> totally
> >> > rock.
> >> >
> >> > I vote for a lab test ... who can test this, PBR, and this scenario?
> >> > "Inquiring minds what to know" ... as the expression goes.
> >> >
> >> > All those in favor of Marko testing this, say "Aye" . I think the
> group
> >> > votes for you Marko ...
> >> >
> >> > ;-)
> >> >
> >> > .
> >> > On Mon, May 2, 2011 at 8:55 PM, < <ron.wilkerson_at_gmail.com>
> >> ron.wilkerson_at_gmail.com> wrote:
> >> >>
> >> >> Most definitely per packet.
> >> >> Sent from my Verizon Wireless BlackBerry
> >> >>
> >> >> -----Original Message-----
> >> >> From: Carlos G Mendioroz < <tron_at_huapi.ba.ar>tron_at_huapi.ba.ar>
> >> >> Sender: <nobody_at_groupstudy.com>nobody_at_groupstudy.com
> >> >> Date: Mon, 02 May 2011 21:45:14
> >> >> To: Marko Milivojevic< <markom_at_ipexpert.com>markom_at_ipexpert.com>
> >> >> Reply-To: Carlos G Mendioroz < <tron_at_huapi.ba.ar>tron_at_huapi.ba.ar>
> >> >> Cc: Brian McGahan< <bmcgahan_at_ine.com>bmcgahan_at_ine.com>; masroor
> ali<<masror.ali_at_gmail.com>
> >> masror.ali_at_gmail.com>;
> >> >> Cisco certification< <ccielab_at_groupstudy.com>ccielab_at_groupstudy.com>
> >> >> Subject: Re: Internet Traffic load balancing
> >> >>
> >> >> This was generated from the switching point ? I.e. it was generated
> by
> >> >> the router having the 5:2 statics ?
> >> >>
> >> >> I would test it from a neighbour, so CEF is used for sure. Local
> trafic
> >> >> is process switched most probably.
> >> >>
> >> >> -Carlos
> >> >>
> >> >> Marko Milivojevic @ 02/05/2011 21:10 -0300 dixit:
> >> >> >> I wonder if we could test this with a simple ping?
> >> >> >
> >> >> > Disclaimer: This is unbelievably unscientific, quick and dirty and
> in
> >> >> > no way proves either point. I still think a proper traffic
> generator
> >> >> > is required.
> >> >> >
> >> >> > I added 7 loopbacks on another router (the one that is default
> >> gateway
> >> >> > for both interfaces):
> >> >> >
> >> >> > 101.100.100.100
> >> >> > 102.100.100.100
> >> >> > 103.100.100.100
> >> >> > 104.100.100.100
> >> >> > 105.100.100.100
> >> >> > 106.100.100.100
> >> >> > 107.100.100.100
> >> >> >
> >> >> > I ran the following from the router with static routes (prior to
> >> this,
> >> >> > I made sure the ARP table was populated and I cleared the counters
> >> and
> >> >> > disabled anything else on the router than can generate packets
> and/or
> >> >> > frames, leaving only my pings in output counters):
> >> >> >
> >> >> > foreach ip {
> >> >> > 101.100.100.100
> >> >> > 102.100.100.100
> >> >> > 103.100.100.100
> >> >> > 104.100.100.100
> >> >> > 105.100.100.100
> >> >> > 106.100.100.100
> >> >> > 107.100.100.100
> >> >> > } { ping $ip repe 1 }
> >> >> >
> >> >> > What I should be seeing is 5:2 ratio in packets. This is what I
> got:
> >> >> >
> >> >> > R2#sh int gi0/0 | i packets out
> >> >> > 4 packets output, 456 bytes, 0 underruns
> >> >> > R2#sh int gi0/1 | i packets out
> >> >> > 3 packets output, 342 bytes, 0 underruns
> >> >> >
> >> >> > Which leads me to my original assumption of 1:1 ratio.
> >> >> >
> >> >> > --
> >> >> > Marko Milivojevic - CCIE #18427
> >> >> > Senior Technical Instructor - IPexpert
> >> >> >
> >> >> > FREE CCIE training: <http://bit.ly/vLecture>http://bit.ly/vLecture
> >> >> >
> >> >> > Mailto: <markom_at_ipexpert.com>markom_at_ipexpert.com
> >> >> > Telephone: +1.810.326.1444
> >> >> > Web: <http://www.ipexpert.com/>http://www.ipexpert.com/
> >> >> >
> >> >> >
> >> >> > Blogs and organic groups at <http://www.ccie.net>
> http://www.ccie.net
> >> >> >
> >> >> >
> >> _______________________________________________________________________
> >> >> > Subscription information may be found at:
> >> >> > <http://www.groupstudy.com/list/CCIELab.html>
> >> http://www.groupstudy.com/list/CCIELab.html
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >>
> >> >> --
> >> >> Carlos G Mendioroz < <tron_at_huapi.ba.ar>tron_at_huapi.ba.ar> LW7 EQI
> >> Argentina
> >> >>
> >> >>
> >> >> Blogs and organic groups at <http://www.ccie.net>http://www.ccie.net
> >> >>
> >> >>
> _______________________________________________________________________
> >> >> Subscription information may be found at:
> >> >> <http://www.groupstudy.com/list/CCIELab.html>
> >> http://www.groupstudy.com/list/CCIELab.html
> >> >>
> >> >>
> >> >> Blogs and organic groups at <http://www.ccie.net>http://www.ccie.net
> >> >>
> >> >>
> _______________________________________________________________________
> >> >> Subscription information may be found at:
> >> >> <http://www.groupstudy.com/list/CCIELab.html>
> >> http://www.groupstudy.com/list/CCIELab.html
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >
> >> >
> >> >
> >> > --
> >> > Andrew Lee Lissitz
> >> > <all.from.nj_at_gmail.com>all.from.nj_at_gmail.com
> >> >
> >>
> >
> >
> >
> > --
> > Andrew Lee Lissitz
> > <all.from.nj_at_gmail.com>all.from.nj_at_gmail.com
> >
> >
>
>
> --
> Andrew Lee Lissitz
> all.from.nj_at_gmail.com
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Tue May 03 2011 - 09:23:11 ART

This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:11 ART