After much dinking around, I came to the solution of tweaking BGP with
a distance command and referencing an ACL that matches my internal AS
routes.
So far in my lab (GNS3) works like a champ. The only thing I'm having
difficulty with is replicating an outage, as GNS3 says Up/Up, but on
link failure/reestablishment everything resumes as it should.
router bgp 65000
distance 180 1.3.3.1 0.0.0.0 7
access-list 7 permit 10.1.1.0 0.0.0.255
access-list 7 permit 192.168.1.0 0.0.0.255
Going to be a slight pain with the 70+ routes/statics at each site,
but once I'm done it will work as expected.
Giddy up!
JB
On Wed, May 18, 2011 at 9:35 AM, JB Poplawski <jb.poplawski_at_gmail.com> wrote:
> Thanks all, I'll give it a whirl on GNS3 and see what I come up with.
> JB
>
> On Tue, May 17, 2011 at 7:45 PM, Joseph L. Brunner
> <joe_at_affirmedsystems.com> wrote:
>> Many people send specific routes on the p2P link and send summaries via BGP
>>
>> Try that :)
>>
>>
>> From: ALL From_NJ [mailto:all.from.nj_at_gmail.com]
>> Sent: Tuesday, May 17, 2011 08:45 PM
>> To: JB Poplawski <jb.poplawski_at_gmail.com>
>> Cc: marc edwards <renorider_at_gmail.com>; Joseph L. Brunner;
>> ccielab_at_groupstudy.com <ccielab_at_groupstudy.com>
>> Subject: Re: EIGRP<->BGP Redistro Question.
>>
>> A thought on all of this ... if you have more specific routes, these will
>> take preference for route selection. Can you summarize either the EIGRP or
>> BGP and cause one or the other to have the more preferred path? Sounds like
>> you want to summarize the BGP and cause the EIGRP to be preferred?
>>
>> When your primary and specific route goes away, the summary route will be
>> the next choice. Kind of a Floating static idea ...
>>
>> Not sure I fully understand your topology but at first thought, this is what
>> came to my goofy mind.
>>
>> HTH
>>
>>
>> .
>> On Tue, May 17, 2011 at 6:35 PM, JB Poplawski <jb.poplawski_at_gmail.com>
>> wrote:
>>>
>>> Good Call, the Site B router is configured as:
>>>
>>> router eigrp 100
>>> redistribute bgp 65000 metric 1500 10 255 1 1500 route-map settag
>>> network 4.7.7.4 0.0.0.0
>>> distance eigrp 10 20
>>> no auto-summary
>>> !
>>> router bgp 65000
>>> no synchronization
>>> bgp log-neighbor-changes
>>> redistribute eigrp 100 route-map blocktag3
>>> neighbor 1.4.4.1 remote-as 4323
>>> neighbor 1.4.4.1 fall-over
>>> neighbor 1.4.4.1 fall-over bfd
>>> neighbor 1.4.4.1 allowas-in
>>> no auto-summary
>>> !
>>> route-map settag permit 10
>>> set tag 4
>>> !
>>> route-map settag permit 20
>>> !
>>> route-map blocktag3 deny 10
>>> match tag 3
>>> !
>>> route-map blocktag3 permit 20
>>>
>>> The problem I run into is that my BGP router learns of the external
>>> routes via EIGRP at first, those external routes disappear with the
>>> link dying, and they come back but the router "hangs on to" the bgp
>>> route. I have to either clear the process or clear the specific route
>>> to get it to fail back properly.
>>>
>>> Anything else you can think of?
>>> JB
>>>
>>> On Tue, May 17, 2011 at 5:19 PM, marc edwards <renorider_at_gmail.com> wrote:
>>> > Your eigrp statement at both sites is specifying only 3.6.6.3 as
>>> > interface 0.0.0.0 is exact match. Are both sites interfaces set with
>>> > 3.6.6.3? Let us know.
>>> >
>>> > Thanks,
>>> >
>>> > Marc Edwards - DCNISS
>>> > http://reno-ccie.blogspot.com
>>> >
>>> > On Tue, May 17, 2011 at 2:25 PM, JB Poplawski <jb.poplawski_at_gmail.com>
>>> > wrote:
>>> >> Good afternoon,
>>> >>
>>> >> I'm attempting to implement a solution and am labbing it up on GNS3.
>>> >> Hopefully someone has some insight, I've chased my tail for awhile
>>> >> here.
>>> >>
>>> >> I have two sites connected via BGP to an MPLS cloud. Each site has
>>> >> static routes that the other site needs access to. Everything works
>>> >> great now. I'm getting a point to point between the two and I'm going
>>> >> to run into a problem. My static routes are EIGRP External and my BGP
>>> >> routes getting redistro-ed into EIGRP as external as well. On initial
>>> >> bootup everything works well. Each site goes through their respective
>>> >> BGP -> MPLS cloud for remote access to the other sites. For the local
>>> >> networks it goes across the point to point link. If I kill that point
>>> >> to point, everything fails over to local BGP router. Site A goes
>>> >> through MPLS to Site B. If I bring that point to point back. All of
>>> >> the internal routes get re-learned via EIGRP and work like a champ.
>>> >> All of the external static routes will continue to go through the
>>> >> local BGP router and not over the Point to Point.
>>> >>
>>> >> My configs are here:
>>> >> ____________________________________________________________
>>> >> Site A
>>> >> router eigrp 100
>>> >> redistribute bgp 65000 metric 1500 10 255 1 1500 route-map settag
>>> >> network 3.6.6.3 0.0.0.0
>>> >> distance eigrp 10 20
>>> >> no auto-summary
>>> >> !
>>> >> router bgp 65000
>>> >> no synchronization
>>> >> bgp log-neighbor-changes
>>> >> redistribute eigrp 100 route-map blocktag4
>>> >> neighbor 1.3.3.1 remote-as 4323
>>> >> neighbor 1.3.3.1 fall-over
>>> >> neighbor 1.3.3.1 fall-over bfd
>>> >> neighbor 1.3.3.1 allowas-in
>>> >> no auto-summary
>>> >> !
>>> >> route-map settag permit 10
>>> >> set tag 3
>>> >> !
>>> >> route-map settag permit 20
>>> >> !
>>> >> route-map blocktag4 deny 10
>>> >> match tag 4
>>> >> !
>>> >> route-map blocktag4 permit 20
>>> >> ____________________________________________________________
>>> >> Site B
>>> >> router eigrp 100
>>> >> redistribute bgp 65000 metric 1500 10 255 1 1500 route-map settag
>>> >> network 3.6.6.3 0.0.0.0
>>> >> distance eigrp 10 20
>>> >> no auto-summary
>>> >> !
>>> >> router bgp 65000
>>> >> no synchronization
>>> >> bgp log-neighbor-changes
>>> >> redistribute eigrp 100 route-map blocktag4
>>> >> neighbor 1.3.3.1 remote-as 4323
>>> >> neighbor 1.3.3.1 fall-over
>>> >> neighbor 1.3.3.1 fall-over bfd
>>> >> neighbor 1.3.3.1 allowas-in
>>> >> no auto-summary
>>> >> !
>>> >> route-map settag permit 10
>>> >> set tag 3
>>> >> !
>>> >> route-map settag permit 20
>>> >> !
>>> >> route-map blocktag4 deny 10
>>> >> match tag 4
>>> >> !
>>> >> route-map blocktag4 permit 20
>>> >>
>>> >>
>>> >> I'm thinking I need to tag the routes when I intro them to EIGRP, but
>>> >> not really sure what that gets me. Any advice or direction would be
>>> >> great. I was thinking about EEM or something, but wasn't sure where
>>> >> to even begin with that. It seems easy enough, One EIGRP with two BGP
>>> >> exit points, but I keep chasing my tail.
>>> >>
>>> >> Any help/pointers are appreciated,
>>> >> JB
>>> >>
>>> >>
>>> >> Blogs and organic groups at http://www.ccie.net
>>> >>
>>> >> _______________________________________________________________________
>>> >> Subscription information may be found at:
>>> >> http://www.groupstudy.com/list/CCIELab.html
>>>
>>>
>>> Blogs and organic groups at http://www.ccie.net
>>>
>>> _______________________________________________________________________
>>> Subscription information may be found at:
>>> http://www.groupstudy.com/list/CCIELab.html
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>> --
>> Andrew Lee Lissitz
>> all.from.nj_at_gmail.com
Blogs and organic groups at http://www.ccie.net
Received on Tue May 31 2011 - 11:06:11 ART
This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:12 ART