From: steven.j.nelson@bt.com
Date: Sat Sep 28 2002 - 10:51:20 GMT-3
Robert
!
interface loopback 0
ip address 131.1.100.1 255.255.255.0
!
interface ethernet 0
ip address 150.1.100.1 255.255.255.0
ip rip receive version 1 2
!
router rip
version 2
network 150.1.0.0
redistribute connected metric 2 route-map connected
!
route-map connected
match ip address 10
!
access-list 10 permit 131.100.1.0 0.0.0.255
In this example the ethernet is not passive as this would block the
advertisment of the loopback subnet, passive does not send any updates but
listens.
I have used rip version 2 as you don't know what version is on R2, so the
Ethernet is set to receive both versions (belt and braces approach). This
config will send V2 so you need to do some debugs to see what is coming in
on your ethernet, if it is a broadcast based rip update it is V1 and if it
is multicast based it is V2.
Although your requirement is not to advertise the ethernet you will not be
"Advertising" it as such because the other end is running RIP on this
network, R2 will see the Ethernet as dircetly connected not advertised via
RIP.
Thanks
Steve
CCIE #10055
-----Original Message-----
From: Robert Massiache [mailto:robert2140@hotmail.com]
Sent: 28 September 2002 10:16
To: ccielab@groupstudy.com
Subject: Can't receive the routes...Help!
Hi all,
I got a questins for you all. Here the R2 is an unkown router running RIP.
No idea about what version. You need to receive the rotues from R2.
loop20-R1----Ethernet----R2
R1:
interface loop 20
131.1.100.1 255.255.255.0
interface Ethernet0
ip address 151.1.100.1 255.255.255.0
router rip
redistribute connected metric 2 route-map west
network 131.1.0.0
route-map west permit 10
match interface e0
route-map west permit 20
!
end.
How can I configure R1 to receive those R2 routes. I should only advertise
the loop 20 I should not advt. the Ethernet.
In all the above trials the RIP is not getting enabled on the Ethernet even
if I use access-list option insdie the route-map. Any help would be
appreciated.
thanks
This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:44:05 GMT-3